Hello Guest it is February 25, 2021, 03:39:21 AM

Author Topic: Homing Sequence  (Read 10789 times)

0 Members and 1 Guest are viewing this topic.

Offline QSRP

*
  •  10 10
    • View Profile
Homing Sequence
« on: February 23, 2013, 05:15:51 PM »
I am setting up my homing switches and I would like to know if there is a way of changing the homing sequence.  Right now my "Y axis" homes before the "X axis".  I would like to reverse this and have the "X axis" home first and then the "Y axis".  Is there a way to do this?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Homing Sequence
« Reply #1 on: February 23, 2013, 05:22:45 PM »
You can edit the VB script in the RefAll button, if you go to Operator menu in Mach then Edit Button scripts you will see the RefAll button flash. Click it and the editor will open, change round the order of the lines so it is as below and that will home Z then X then Y then A.
DoButton( 24 )
DoButton( 22 )
DoButton( 23 )
DoButton( 25 )

Hood

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Homing Sequence
« Reply #2 on: February 23, 2013, 05:27:05 PM »
Yes, look in your ref all vb button.  Click on the user tab then edit button scpipt.  All vb buttons on the screen will begin to flash, raf all is one of them.  I think it will be 24 for z, 23 for y, 22 for z.  Just change the 23 and 22 around.  Watch it close and make sure it does what you want after you change and save your changes.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline QSRP

*
  •  10 10
    • View Profile
Re: Homing Sequence
« Reply #3 on: February 23, 2013, 08:12:47 PM »
Thanks Hood and Chaoticone for your help.  That solved my original issue but somehow it created another.  Now when the home switches make contact, they do not back off.  As soon as one axis hits the switch, that axis stops and the next begins.  It does this for all 3 axis.  Any thoughts on this?

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Homing Sequence
« Reply #4 on: February 23, 2013, 08:26:03 PM »
What hardware are you running?  Smooth Stepper? Do have any slaved axis?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Homing Sequence
« Reply #5 on: February 23, 2013, 08:32:39 PM »
Also, what version of Mach are you running?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Homing Sequence
« Reply #6 on: February 24, 2013, 04:31:30 AM »
Do the LEDs turn green and machine coords get set to zero?
Hood

Offline QSRP

*
  •  10 10
    • View Profile
Re: Homing Sequence
« Reply #7 on: February 24, 2013, 10:08:33 AM »
Thanks again for your help Hood and Chaoticone.  Let me give you the whole story here as well as what I am using.

When I posted this thread, I was running MACH3 Version R1.84.002, which is what came with the controller when I bought it.  I have not used this for a while and here recently I installed 3 Home switches.  One for the "X axis ", One for the "Y axis" and One for the "Z axis".  I got everything wired up and configured in the inputs section of the Pins & Ports configuration and in the Home / Limit configuration.  At this point everything worked just fine except for the Homing order.  It would start out with homing the "Z axis" and when it hit the Home switch, it then reversed direction until it came off of the switch.  It then did the same for the "Y & X Axis".

I then posted the thread and both responses were directing me to the Operator menu in Mach3 and then Edit Button scripts for the RefAll button.  Because this option is not in the R1.84.002 version, I downloaded the latest version of Mach3, Version R3.043.066, and installed it.  I made all the config changes and changed the homing order.  And this is when the new issue popped up.  The Homing order is what I prefer, "Z, X, Y", but now when each of the 3 Axis hit the Home switches, they trip the switch, LED turns Green and the next axis starts homing without the previous axis not backing off of the switch.

Is this normal?  How do I fix it so the back off of the switches?

I am running the following:

Controller:
CNC Stepper System by Camtronics, Inc.

Stepper Motors:
MCG
2phase  1.8 step motor
1.3A, 0.5 Ohms, 18.61 W

Thanks for everyones help.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Homing Sequence
« Reply #8 on: February 24, 2013, 10:22:06 AM »
Ok because the LEDs are turning green then that means Mach has seen the switches being triggered, backed off until they close and then set machine coords, so looks like it is working fine. What I suspect is you possibly had a high debounce in your previous setup and thus the signal that the switch had closed was being delayed.
Hood

Offline QSRP

*
  •  10 10
    • View Profile
Re: Homing Sequence
« Reply #9 on: February 24, 2013, 11:16:05 AM »
Thanks Hood but I am very confused now.  You state, "because the LEDs are turning green then that means Mach has seen the switches being triggered, backed off until they close and then set machine coords, so looks like it is working fine."  This is not happening though.

Since I have installed the switches, the machine has not touched any of the switches.  I have all the axis in the middle of their travel.  when I hit the "Ref All Home", the axis moves but before I gets to the switch, I manually depress the switch.  In the older version, once I tripped the switch, it reversed direction until I let off of the switch breaking the contact.  The next axis did not start until the previous switch was backed off and opened the contact.  All my home switches are normally open.

Now with the version, I am doing the same thing but now when the first axis switch is tripped, the next axis starts without my breaking the contact of the first switch.

Why do the axis not reverse direction when the switch makes contact with the newer version?  I would just go back to the older version that worked correctly but I cannot find anywhere in it where I can change the homing order.  I have to have the homing order "Z, X, Y because of the switch locations.