Hello Guest it is November 27, 2021, 12:47:28 AM

Author Topic: Mach 3 crash - cant recover  (Read 2090 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 crash - cant recover
« on: February 23, 2013, 07:01:18 AM »
Firstly hello to all from Danny in Australia. I have a ZX30 mill that I converted to CNC about 3 years ago for cutting out mostly small alloy parts. I have always used Mach 3 to operate the machine with zero problems in this time. Some time ago I had the power supply in the computer fail, it was replaced and that had no effect on any of the programming which was good news at the time too. Today I ran into a problem - it wasn't a "blue screen crash" as I have heard about, rather the Mach 3 program shut itself down as I opened a G code that I had used many times before. The computer (PC) then also restarted itself all by itself and it did this a few times. I turned it off at the wall to let it cool down for a while. On restarting the PC, I noted that all other programs functioned just fine but the Mach 3 had changed and no longer fitted the screen properly. I found there were no configuration settings or those that were there  had reverted back to 1 or zero. I tried the "restore settings" under "Operator" and would only come up with "trigger error". When I cancelled that operation, Mach 3 would then shut itself down so I could not restore to any previous settings that worked. I tried to restore the PC itself. The restore worked but this had no effect on the Mach 3 program. I changed configurations manually using the info from the Mach3_install_config pdf with some result. Without any wiring or cables being changed, X axis would only go in the same direction when jogging left or right - Y axis did nothing at all in either direction and Z axis was actually controlling the Y axis but only in the one direction like Z. Triple checked the cables and the configuration settings and all looks good but still the same problem. Bit the bullet and uninstalled the Mach 3 program - restart PC - reinstall Mach 3 - restarted again - now it says my license isn't valid but the program still opens. Reconfigured it all again with exactly the same result as before the re-installation as far as the  X Y & Z drives not functioning correctly. I also noted that small G-code files opened and display correctly but larger files do not appear in the tool path window, just the G-code but it doesn't start at the beginning of the code as it should.

The PC that drives the machine is not connected to the internet. This PC is and I have Mach 3 installed on it as it's where I design and edit a lot of my work before transferring it out to the machine room on a memory card. I will in the next few days, take this PC out to the machine room to see if it will drive the rest of the system. That will eliminate any drive box, cable or stepper motor errors.

I nice little pickle for my first post on this forum, I guess I'm asking if anyone has come across such a problem before or if anyone has any ideas on where to start. I'm thinking this is going to be a problem with either the PC software, PC serial port, PC to drive box cable, drive box itself, not likely but the stepper motors themselves causing an issue.

Any help or suggestions much appreciated. Regards, Danny.

Re: Mach 3 crash - cant recover
« Reply #1 on: February 23, 2013, 09:06:14 AM »
Hi Danny,  I haven't a solution just a bit of information you might find usefull. I had a Dell computer running my system for years with no problems  then Mach started stopping half way thru a program after a few re-starts it would be fine and work all day. Then the computer would not come on, I summised it was the computers power supply that had failed. Bought a secondhand power supply off ebay, put it in and all run fine for a few days. Then it failed again, Mach started doing funny things like tripping out on limit switches, then the spindle started to go wrong, screen sometimes loaded in 4-3 format then 16-9 without warning. Finally found out it was not the computers power supply but a problem with the mother-board which had developed an intermittent fault which finally shorted and blew the system. So bought a secondhand Dell Optiplex 3300 (with the printer port for connecting to BOB), and all has been fine (fingers crossed) except for a slight spindle drive board problem with a dodgy capacitor I intend to fix asap. Guess what I'm saying it could be a computer failure or hard drive fault, especially as it sometimes loads half a file onto your Mach screen. Hope this helps. Jim UK
Re: Mach 3 crash - cant recover
« Reply #2 on: February 24, 2013, 11:51:27 PM »
Hi Jim, Thanks for your reply. I've fixed it - I found that the Xylotec drive box and stepper motors to operate the machine uses different pin numbers to the standard set of step and direction numbers that comes with the Mach 3 program. I must have found this 3 years ago when I initially set up the machine but has simply forgotten about it this time. Once I made the changes to the motor outputs in the ports and pins dialog, the motors worked just fine.

Unfortunately this still doesn't answer why it crashed and burned in the first place but at least it's up and running again. One small issue I have come across is the "run from here" command doesn't function at all. I don't use that function much anyway but is handy some times so I will look into it later.

Regards, Danny.