Hello Guest it is May 25, 2019, 12:23:43 AM

Author Topic: Go To Z but ignore A  (Read 1786 times)

0 Members and 1 Guest are viewing this topic.

Go To Z but ignore A
« on: February 11, 2013, 04:04:44 PM »
Hey everyone,

I modded my router to double as a 3D printer.  I'm using Mach3 and often have prints that fail and I have to restart.  The extruder is on the A axis and as it runs, it builds up distance in the DRO.  When I want to go back to Z (0 on X,Y,Z),  it also reverses the extruder gear to try to bring it back to 0 as well.  Is there any way to disable the A axis as being part of the Go To Z routine?  Or alternatively auto 0 it whenever I stop Mach?  I can't seem to find a setting for it, but then again, I'm not sure what I am looking for.

Thx

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: Go To Z but ignore A
« Reply #1 on: February 11, 2013, 05:02:40 PM »
Best idea would be to guse a screen editor and change the Go To Z button into a VB button and then when back in Mach go to Operator menu then Edit Button Script. You can then enter some VB to make X Y Z go to zero and A will not move.

I can help with the code if you are unsure. I would need to know do you require the Z to rise before X and Y  then go back down to zero once they are at zero.

Hood
Re: Go To Z but ignore A
« Reply #2 on: February 12, 2013, 07:01:39 AM »
Thx for the offer. I was hoping for an easy fix, such as a configuration setting that could be changed.  Is this the only way to do this?

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: Go To Z but ignore A
« Reply #3 on: February 12, 2013, 04:24:44 PM »
Go To Zero is what it says, sends all active axis to zero so no way to do it other than a custom button or MDI or you could probably inhibit the A before you press the standard button. Easiest would be to make the custom button, only takes a few seconds to do.
Hood