Hello Guest it is October 16, 2019, 08:57:44 AM

Author Topic: Problems with Mach3 Turn and tools  (Read 3815 times)

0 Members and 1 Guest are viewing this topic.

Problems with Mach3 Turn and tools
« on: February 05, 2013, 06:01:27 AM »
Hello I´m new here and my name is Giovanni

Since a few month I got a Lathe with CS-Lab as Hardware and Mach3 Turn.

The machine works precise and pretty well but I got a litle problem when i work with more tools.

When I start a program , than my first tool T0101 works perfect and it starts instandly when I push the start button.

Now when the first tool finished its work and I change to tool2 T0202 than I push start and normaly now the tool hase to move to G0 X30 Z20 ( only for example). But the tool moves not instandly to this position . It first run to a position I didn´t know. In my case the tool runs to X0 and very very slowly. After reaching this position , the tool continues with following the program and run with G0 to X30 Z20.

And the same thing with tool3 T0303 and so on. Only the first tool starts perfect following the program .

I realy don´t know what´s the cause of this issue. The tools seems set perfect because the parts I turn are good and no issues with that.

But this issues that the tools take a long time till they start with the program is strange and I didn´t get it where the mistake come from.


Who can help me with this matter ??

Thank You

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Problems with Mach3 Turn and tools
« Reply #1 on: February 05, 2013, 07:00:12 AM »
Sounds like you may have someting in the M6End macro.
If you attach your xml I will check that and also if you can attach the m6start and m6end macros from the macro folder of the profile you are using.
Hood
Re: Problems with Mach3 Turn and tools
« Reply #2 on: February 05, 2013, 07:04:29 AM »
Hi Hood ,

thank you a lot . After work I will atteach the macros and the XML. Hope strongly that you can help me.

Till later

Giovanni

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Problems with Mach3 Turn and tools
« Reply #3 on: February 05, 2013, 07:06:44 AM »
Which CS-Lab control do you have? I have the CSMIO/IP-S on the wee lathe.
Hood
Re: Problems with Mach3 Turn and tools
« Reply #4 on: February 05, 2013, 07:18:41 AM »
Yes I got the CSMIO/IP-S too on a Optimum Lathe.

I find it very professional and the machine at all is very precise. I reach measures within 0.01mm. And its the only issue at the moment that realy sucks.

Immagine you can turn a piece in 2minutes...I require 4minutes because of the issues with the tools.

The other Issue is when you want to get in the program and start for example from tool2 ....it didn´t work at all. But this for me is not so important. I can take this.


Hood ..which firmware do you use on the CSMIO/ IP-S ? I use the 1.66 or so...the latest one didn´t work . I tried it a few days ago.

Gio

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Problems with Mach3 Turn and tools
« Reply #5 on: February 05, 2013, 08:01:45 AM »
I use 1.900, 1.925b has an issue with the J when jogging via MPG, it is jerky.
Hood
Re: Problems with Mach3 Turn and tools
« Reply #6 on: February 05, 2013, 09:15:24 AM »
Hi Hood ...already sended the file to you.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Problems with Mach3 Turn and tools
« Reply #7 on: February 05, 2013, 10:37:57 AM »
Assuming that is the correct macro you sent then your M6End one is likely causing your problems. In the lathes M6End macro it is normal to not have anything. If you go to Operator menu then VB Editor and then browse to your lathe profiles macro folder and open the M6End macro and delete everything in it then save and exit and see if that cures your problem.
Hood
Re: Problems with Mach3 Turn and tools
« Reply #8 on: February 05, 2013, 12:15:25 PM »
Hi Hood......I hope so much that this the cause of all  :D

I will try it later and tell you about .

I´m not an expetise in this things. I can work with metal lathes and others ...but this things I didn´t know at all. So my question to understand better .

Can you explain me shortly what this macro in my case is done with the program? I assume that if you can tell me all this things, you surly are able to read this macros.  Maybe it helps me to understand better the function of macros. I opened this macro and yes there are some things that in the demo version are not in.


I will tell you about after testing it .

bye
Gio
Re: Problems with Mach3 Turn and tools
« Reply #9 on: February 05, 2013, 01:30:26 PM »
Hood.........You are the men ;D Works perfectly .  I don´t know how to thank you. its a few weeks that I mess around with this problem and no one here in germany
could help me.

You did and I thank you so much.

Thank you
and Very best regards

Gio