Hello Guest it is November 14, 2019, 11:34:03 AM

Author Topic: problem settings -need help  (Read 2108 times)

0 Members and 1 Guest are viewing this topic.

problem settings -need help
« on: February 04, 2013, 06:01:53 AM »
hi,
i am new to mach and i am trying to setup a mill system.i have smooth stepper and pmdx 126 board.
i need help for basic settup. here is my thoughts:
i have steppers with 200 steps/rev
i set microstepping to 16 so i will have total 200*16=3200 steps per rev OK?
the ballscrew pitch is 5mm per rev so should i input 3200/5=640 steps per unit at the motors setup?

1)what microstepping should i use for a mill bf20 machine (g0604 equivalent)

i have problems with the jog stepping too. for example if i set the jog step to 0.01 i do not see 0.01 steps at the dro when i jog i see 0.0104 -> 0. 0208 -> 0.0299 ...
2) what is going on?units are in mm

3)i set the max speed at the 600 at the motor setup screen . why my max speed is at 72units/min at the feed screen ?

4)limits :
is the mach3 moves  all the axis simultaneusly when homming or is it homes one axis at a time? i  am trying to find out how many limit switches i need. yes the x-- and home x , y-- and home y, z++ and home z  share the same switch so finaly i will need 3+3=6 switches?
i what inputs? input pins are the 10-13 and 15. the 10 is reserved for estop.
11 > x-- and home x
12 > y-- and home y
13 > z++ and home z

is it ok if i use the inputs for the seccond port of the SS for the x++,y++ and z-- ?

thanks
i apreciate any help





Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: problem settings -need help
« Reply #1 on: February 04, 2013, 07:05:11 AM »
Are you sure your screws are 5mm per rev. or are they .200 inch per rev?  Is this documented somewhere or a measurement you took?  The math on your steps per is right so far if they are 5mm per rev.  Are the steppers driving the screws at a 1-1 ratio?  If there is any gearing that will have to be taken into account.  

Not sure what you will want to set the microstepping to.  This will have bearing on your next question as well.  I would try to set my microstepping so that I could achieve the max resolution I want.  You find this by dividing the steps per by that resolution.  10,000/640=15.625.  This is why you see 0.0104 with one pulse and then 0.0091 later.  You can't hit your resolution evenly so the best your machine can do is get as close as possible by adding or subtracting a step.  It would be best if your desired resolution is .00 if you could get your steps to 100 or something that can be divided evenly by 100.

I'm guessing the 72 units a minute is what Mach's default slow jog speed is set to.  Holding down the shift key and then jog will do a rapid jog which would be what you have your motor tuned to.

Mach should home one axis at the time.  You can put all limits and homes to one input from Mach or each to an individual one just make sure you have them wired correctly which ever way you choose.  Pin assignment just depends on where you wire them to.  You can put them on the second port of the SS if you want to.

This may help as well.  http://www.machsupport.com/docs/Mach3Mill_Install_Config.pdf

Brett

 
« Last Edit: February 04, 2013, 07:07:41 AM by Chaoticone »
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: problem settings -need help
« Reply #2 on: February 04, 2013, 09:23:56 AM »
Brett,
yes, the ballscrew pitch  is 5mm per rev.i checked the driver manual and there is a 10 microsteping setting . so i will have 200*10(microsteping)/5(pitch)=400 steps/1mm
with taht way everything is rounded to 0.01 mm

the problem with the max speed is not fixed. the slow jog setting is set to 100% so if i press the shift or not doesnt matter. i am still limited to 72 units /min max speed.
i do not know what am i missing.
also noted that i cannot jog simultaneusly x and y or z axis. is that normal?is there any setting for jogging both axis the same time?


question about diagnose screen. can i simulate a limit switch signal by pressing a key? there is a simulation button in that diagnose screen but does not seems to do annything..


thanks!

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: problem settings -need help
« Reply #3 on: February 04, 2013, 10:18:47 AM »
I think your slow jog may be due to the machine not being refrenced.  Once you do a sucessful home, I think that will go away and you will be able to rapid.  That may be why you can only jog one axis at the time as well.  You can test this by disabeling your home switches in config, ports and pins, inputs and refrencing the machine.  That will make the machines current position machine 0.0000.  Just rememeber, when testing, slow things down and be ready to stop it should it not act as you expect.   

I'm not sure about the simulate button on the diag. screen (mine doesnt have it) but you can emulate the limit switches by setting them to do so and assigning a hot key in config, ports and pins, inputs.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!