Hello Guest it is September 18, 2021, 01:40:46 PM

Author Topic: All stepper motors run on their own when spindle is turned on  (Read 2971 times)

0 Members and 1 Guest are viewing this topic.

All stepper motors run on their own when spindle is turned on
« on: January 31, 2013, 06:38:46 AM »
When in home position the motors try to move negative, when spindle is away from home motors move away from home!

I have stepper motors set up nicely they  jog and home correctly via Mach3 when spindle is not spinning.

The spindle connects to VFD but not desktop and runs ok when only the stepper motors control box is on. When mach3 is opened up the problem starts when I get spindle rotating.

I have not touched any of the spindle settings in Mach3 and are set at default.

The cnc machine is 6040z and recommended x/y motor profile is 640 steps per, velocity 2500 mm/min, acceleration 200 mm/s/s, step pulse 5 and direct pulse 1. The z profile is 640,800,150,5,1. I am not able to set the x/y recommended profile as the velocity 2500 is off the scale and I am only able to get 2300, does this matter?

I would appreciate any help on this, thank you

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: All stepper motors run on their own when spindle is turned on
« Reply #1 on: January 31, 2013, 10:15:14 AM »
Hey ribbo58, welcome to the forum!

If the dros in Mach are not changing then Mach is not telling it to move.  It sounds like your picking up noise.  Here are a couple of links that explain electrical noise and how best to protect signals and components from the negative effects it can have.  Shielding your step and direction cables if their not already would probably be a good start I'm guessing, but that is only a guess.  

http://www.mccdaq.com/PDFs/specs/Noise-Reduction.pdf
http://machinedesign.com/article/top-tips-on-squelching-electrical-noise-0619

Not being able to tune to the max speed should not matter.  This is because of your steps per unit/Kernel speed relationship.  What is your Kernel speed set to in Config, ports and pins, Port setup?  You may be able to raise the kernel speed and reach your max speed but I would not suggest that right now.  I'd try to get it operating rock solid first.  A kernel speed setting that is higher than the PC can produce reliably can cause you to pull out hairs too  :P.  No sense fighting 2 wars at once.

Brett  
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: All stepper motors run on their own when spindle is turned on
« Reply #2 on: January 31, 2013, 03:32:40 PM »
Thanks for your advice Brett

I can see that increasing the kernal speed will allow higher velocity on motor profile which I will look at later, thank you.

I have looked at the noise potential and have ensured all cables are well apart.

Narrowing down the issue I have noticed that the parallel port in the stepper motor control box causes the problem when the lead is attached even when other end is  not attached to the PC. When this port is left empty the spindle will not affect the stepper motors which are still engaged.

This port works ok when jogging the stepper motors from Mach3 though.

Confused!!