Hello Guest it is May 23, 2019, 01:48:37 PM

Author Topic: Stepper Hiss - Noise  (Read 2256 times)

0 Members and 1 Guest are viewing this topic.

Offline Zig

*
  •  28 28
    • View Profile
Stepper Hiss - Noise
« on: January 07, 2013, 03:56:35 PM »
I'm new here - been poking around this forum for a month or two and have built (90% done) a CNC machine.  I can drive the X, Y, and Z steppers all around and everything seems to be working okay.  I still need to fine tune the speeds of everything, but for the moment I'm getting good response.  The thing that is really annoying is the hiss wine chirpyness of the steppers when they are idle. 

When I turn on the power supply for the three steppers (nema23 units) they start to hiss, then when I turn on the computer they really hiss, and when I start Mach3 they go nice and silent.  But as soon as I reset all DROs the symphony of hiss begins.

I've seen some posts about an idle setting.  I'm open to suggestions.  Many thanks.

Zig

Offline Hood

*
  •  25,813 25,813
  • Carnoustie, Scotland
    • View Profile
Re: Stepper Hiss - Noise
« Reply #1 on: January 07, 2013, 03:59:14 PM »
Would help if you mentioned the drives you have.
Hood

Offline Zig

*
  •  28 28
    • View Profile
Re: Stepper Hiss - Noise
« Reply #2 on: January 07, 2013, 04:27:45 PM »
Thanks for the quick reply.

Ummmmmm - Using Mach3 with Nema23s, but I'm sure that's not what you need.  Where could I check for the drive information?

Thanks.  I do appreciate the help.
Zig

Offline Hood

*
  •  25,813 25,813
  • Carnoustie, Scotland
    • View Profile
Re: Stepper Hiss - Noise
« Reply #3 on: January 07, 2013, 04:30:01 PM »
The wires from the motors will connect to the drives.
Hood

Offline Zig

*
  •  28 28
    • View Profile
Re: Stepper Hiss - Noise
« Reply #4 on: January 07, 2013, 05:52:20 PM »
Roger that.  I went the affordable (cheap) route for my first CNC build - using a TB6560 board.

Thanks,
Zig

Offline Zig

*
  •  28 28
    • View Profile
Re: Stepper Hiss - Noise
« Reply #5 on: January 07, 2013, 06:08:06 PM »
Just thinking here - I wonder if it is the dip switch settings...?  They're currently set to 50%.

I'll have to play with the switches tomorrow and see if perhaps changing the current settings will make a difference.

Zig

Offline Hood

*
  •  25,813 25,813
  • Carnoustie, Scotland
    • View Profile
Re: Stepper Hiss - Noise
« Reply #6 on: January 07, 2013, 06:19:52 PM »
If it is a TB type driver board then I think they tend to hiss.
Hood