Hello Guest it is November 15, 2019, 05:08:40 AM

Author Topic: Axises not feeding continuously  (Read 1582 times)

0 Members and 1 Guest are viewing this topic.

Axises not feeding continuously
« on: January 06, 2013, 11:26:48 PM »
I just built my cnc machine, everything seems to be working fine except all three axises x/y/z are not feeding continuously, even with a simple G0 X2 command, it moves->pauses->moves again->pauses->moves again,pauses....so on and so forth, it's roughly 1~2 seconds for each movement, then pauses, then the movement starts immediately again, all three axises behave the same, there are 5 pauses per inch of movement. However, manual jogging using either the buttons/hot keys on mach3 screen or an external serial controller can move all three axises continuously, so it does not look like a hardware cnc controller issue. It's very annoying, like the machine is tired and needs a rest for each movement, I have tried different options and could not figure it out. I have tried mach3 v1.8 and v3, setting different frequencies(25/35/45/1MKHZ), continuous feed/exact stop options.

The problem does not seem to be affecting anything, the machine moves accurately, no skipping. Each time when the axises pause, I can see the track on the tool path screen pauses too and print a little dot, I am not sure if this behavior is normal or is related to the computer, I am using IBM T41(with ACPI disabled).

Any idea?

Thanks!

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Axises not feeding continuously
« Reply #1 on: January 07, 2013, 02:32:03 AM »
Have you read on the main page where laptops are "NOT" recommended ??

Just a thought, (;-) TP

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Axises not feeding continuously
« Reply #2 on: January 07, 2013, 03:06:41 AM »
As TP says Laptops can be problematic. Run the driver test and see if its ok, if it has spikes then that is the problem. It is sometimes possible to get a laptop running fine, sometimes it is not and the only option in that case,  if you must use it, is to use an external pulsing device such as the SmoothStepper or PoKeys etc

Hood
Re: Axises not feeding continuously
« Reply #3 on: January 07, 2013, 11:42:25 AM »
My cnc works after disabling all startup entries from msconfig, it runs like professional! Thanks everyone!