Hello Guest it is May 19, 2022, 07:04:22 AM

Author Topic: Steps per and velocity Problem (solved)  (Read 3130 times)

0 Members and 1 Guest are viewing this topic.

Steps per and velocity Problem (solved)
« on: January 03, 2013, 07:45:53 AM »
Hi all, I have had Mach3 since 2011 and used it on a small bench top CNC mill I built, Mach 3 worked well but the the mill had a few short comings. So -- moving on I was given a medium size mill on a stand less a spindle motor. I had purchased a spindle motor, Steppers and drivers for my other big project on the horizon. I decided to utilize these on my new second hand mill. I made the decision to do one axis at a time, starting with Z. I machined up the spindle brackets the stepper brackets and screw bearing plates on my lathe, Tricky!!! for me, inexperienced. Getting all excited I wired up my stepper and spindle motors and they both worked. Really excited I started to calibrate the stepper. Steps per and velocity changes in motor tuning and setup, had no effect!!!! ???? in and out of all setting and the manual nothing seemed to fix the problem. Reinstalled mach3, uninstalled and reinstalled earlier version still no change Searched the net seemed like no one else had the problem, setup and installed mach3 on another computer, still same problem. I sent an email to support they recommended changing my acceleration setting this also did not change, none of the changes made in motor tuning and setup had no effect on the motors performance. I was about to put this problem out on the forum in frustration, when I stepped through settings one last time, step by step slowly, thinking i am missing something simple and stupid. Simple it was,---- stupid, wellllll mayyy beeee Ill let you all be the judge.
1. I setup one axis Z, the other X and Y I have disabled.
2. When I went in to motor tuning and setup all axis were greyed out except Z
3. I put in my calibrations then saved and OK.
4. Tested the spindle to one inch ---- actual travel .290"
5. Went to the settings tab and used mach3 auto calibrate.
6. Tested spindle movement ---- stepper screamed, moved about .5" and stalled
7. Back into motor tuning and setup, found numbers unchanged
8. This time and I can’t explain why but I clicked on the Z axis button even though it was the only highlighted button and I assumed the calibration numbers belong to Z.
9. Hey presto another set of numbers appeared --- the real numbers.
10 All now works Fine
The moral of this long story is take nothing for granted -------- at 66 you think I would have learnt that lesson.

Hope this helps someone else.
« Last Edit: January 03, 2013, 07:58:15 AM by jecomp »

Offline Tweakie.CNC

  • *
  •  8,918 8,918
  • Super Kitty
    • View Profile
Re: Steps per and velocity Problem (solved)
« Reply #1 on: January 04, 2013, 05:46:50 AM »
We never stop learning John (hopefully).

Thank you for sharing your experience.