Hello Guest it is April 25, 2019, 08:32:56 PM

Author Topic: Ref all home details with reset and auto zero.  (Read 6497 times)

0 Members and 1 Guest are viewing this topic.

Ref all home details with reset and auto zero.
« on: January 02, 2013, 07:59:01 PM »
Hello people,

I'm a newbie, using the demo version R3.043.066
I'm wiring a CNC machine limit switches.
The machine is three-axis.
The X axis with one motor
The Y axis with two motors (A slave)
The Z axis with one motor

The input signals:
X++,     enabled, port 1, Pin 10, Actived low X, Emulated, HotKey 0
X--,       enabled, port 1, Pin 10, Actived low X, Emulated, HotKey 0
Xhome, enabled, port 1, Pin 10, Actived low X, Emulated, HotKey 0
Y++,     enabled, port 1, Pin 11, Actived low X, Emulated, HotKey 0
Y--,       enabled, port 1, Pin 11, Actived low X, Emulated, HotKey 0
Yhome, enabled, port 1, Pin 11, Actived low X, Emulated, HotKey 0
Z++,     enabled, port 1, Pin 12, Actived low X, Emulated, HotKey 0
Z--,       enabled, port 1, Pin 12, Actived low X, Emulated, HotKey 0
Zhome, enabled, port 1, Pin 12, Actived low X, Emulated, HotKey 0
A++,     enabled, port 1, Pin 13, Actived low X, Emulated, HotKey 0
A--,       enabled, port 1, Pin 13, Actived low X, Emulated, HotKey 0
Ahome, enabled, port 1, Pin 13, Actived low X, Emulated, HotKey 0

In the diagnostic screen: I see the Input Signals current state all work fine.

Then when I click the "Ref all home" button.

...Press Reset... Emergency Mode Active...
Limit Switch Triggered


After that.

I proceeded to disable the Z++ and Z--
...and hurrah, the "Ref all home" continued with the Y axis.

Then the Y axis work very well with the three signals
"Y++", "Y--" and  "Y home".  All signals enabled.

...and the "Ref all home" continued with the X axis.

Then the message again:

...Press Reset... Emergency Mode Active...
Limit Switch Triggered


I proceeded to disable the X++ and X--
...and hurrah, the "Ref all home" continued until completion.

In the home/soft limits: I check enabled the Auto Zero in all axis.

Then the questions:

1.- Why not run the X and Z axis auto zero returning?
(M3Home and M1Home is on in diagnostics screen)

Note:
The Y axis work fine with the three signal Y++, Y-- and Yhome
and not active the Emergency Mode y run the autozero returning.

The only thing I find different is that the "Y" axis has slave "A".

2.- For safety on my machine. Like the Y axis.
I want to activate the signals Z++, Z--, X++, X--.

without triggering Emergency mode active, like the Y axis.

How to configure this?


I have thought that it is a software error Mach3

I can fix with wiring, but sought a solution with Mach3



Any case appreciate any related information.

I appreciate your time and attention.

Offline Hood

*
  •  25,785 25,785
  • Carnoustie, Scotland
    • View Profile
Re: Ref all home details with reset and auto zero.
« Reply #1 on: January 03, 2013, 04:08:57 AM »
Sounds like you either have bouncing switches or noise being picked up by your cables. Set a debounce Interval of 2000 in General Config and see if that helps. If it does then you really should sort the problem, ie make sure your cables are shielded and properly grounded or replace with switches that have a positive snap action.
Hood
Re: Ref all home details with reset and auto zero.
« Reply #2 on: January 03, 2013, 03:44:24 PM »
Sounds like you either have bouncing switches or noise being picked up by your cables. Set a debounce Interval of 2000 in General Config and see if that helps. If it does then you really should sort the problem, ie make sure your cables are shielded and properly grounded or replace with switches that have a positive snap action.
Hood

Thanks a lot.

Still do not understand what is debounce Interval,
I need to read and I'll read PDF support.

I setting debounce Interval of 2000
and the index debounce like was = 0

Finally the three axes working properly.
I am very happy and grateful to you for your help.

I can only other detail,
When beginning Ref all home,
buttons ZeroX, ZeroY, ZeroZ, Zero4 every turn red,

then the engines do their job until limit switch,
Then one by one the buttons change to green, excellent.

Zero 4 is only red (that does not bother me).

When finished
The problem is that is yellow "AbNormal Condition".


I think I should not disable motor 4 ("A-axis"), that is slave axis Y.
I do not know if I need any change setting
Or if I need to make a change to the code script:

DoButton( 24 )
DoButton( 23 )
DoButton( 22 )
'DoButton( 25 )  ' I try remark but not fine.

DoOEMButton(133)
DoOEMButton(134)
DoOEMButton(135)
 
I appreciate any related information.

I appreciate your time and attention.



Offline Hood

*
  •  25,785 25,785
  • Carnoustie, Scotland
    • View Profile
Re: Ref all home details with reset and auto zero.
« Reply #3 on: January 03, 2013, 04:27:00 PM »
The Debounce Interval simply adds a delay into Mach when it sees a signal. If you have electrical noise being picked up by your switch wiring then Mach can think it is a limit switch being triggered. The best approach is to use shielded wire and ground one end of the shield to a star point ground.

Regarding the Abnormal Condition, click on it and see what it says, if it is just something about axis not referenced to normal just ok it to clear and set that as normal.
Hood
Re: Ref all home details with reset and auto zero.
« Reply #4 on: January 03, 2013, 06:00:11 PM »
The Debounce Interval simply adds a delay into Mach when it sees a signal. If you have electrical noise being picked up by your switch wiring then Mach can think it is a limit switch being triggered. The best approach is to use shielded wire and ground one end of the shield to a star point ground.

Regarding the Abnormal Condition, click on it and see what it says, if it is just something about axis not referenced to normal just ok it to clear and set that as normal.
Hood

Thank you again.

-List of Abnormalities-
Axis are not Refed to Normal Condition...

Offline Hood

*
  •  25,785 25,785
  • Carnoustie, Scotland
    • View Profile
Re: Ref all home details with reset and auto zero.
« Reply #5 on: January 04, 2013, 02:50:06 AM »
Thats what I thought it would be, just tell Mach that it is a normal condition by clicking on it and you should not see that again.
Hood
Re: Ref all home details with reset and auto zero.
« Reply #6 on: January 05, 2013, 04:03:41 PM »
Thats what I thought it would be, just tell Mach that it is a normal condition by clicking on it and you should not see that again.
Hood

Your help has been extremely useful.

I appreciate and thank you for your time and attention you gave me.

Sincerely.

Offline Hood

*
  •  25,785 25,785
  • Carnoustie, Scotland
    • View Profile
Re: Ref all home details with reset and auto zero.
« Reply #7 on: January 05, 2013, 04:22:46 PM »
Not a problem :)
Hood