Hello Guest it is April 21, 2019, 11:11:28 AM

Author Topic: Mach 3 Blue screen probing  (Read 6186 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 Blue screen probing
« on: December 29, 2012, 03:40:22 PM »
Posted problem in probing did not get a anything back.
I have loaded the Mach blue screen probing, the feed rate defaults to 4 units per min this is too slow, I have looked at the VB script but this is not driven from the script, it is looking at feed rate DRO (818) when I change it on the settings screen it does not retain the value of the DRO the script is coded to retrieve from.
 Where should I enter the feed rate to lock it down. Everwhere I have tried to enter it then run the macro it still goes back to 4.
Any help would be good or any tips to fix it and get it working, it is beating me up.
Thanks.

Offline BR549

*
  •  6,863 6,863
    • View Profile
Re: Mach 3 Blue screen probing
« Reply #1 on: December 29, 2012, 05:29:59 PM »
The mach blue screens were done YEARS ago by individuals that may not even be online anymore to answer your questions.

Just a thought, (;-) TP

Offline BR549

*
  •  6,863 6,863
    • View Profile
Re: Mach 3 Blue screen probing
« Reply #2 on: December 29, 2012, 05:51:04 PM »
If you are talking about the Big Tex Screenset then the Feedrate is hard coded in the button codes.   I believe what you think is feedarte code is simply saving the current feedrate so it can be returned to the original feedrate.

Just open the buttoncode in the CB editor and change the F4 to  F(whatever you want) then save.

(;-) TP
Re: Mach 3 Blue screen probing
« Reply #3 on: December 30, 2012, 09:21:48 AM »
In the button code there is only "F" in red text the probing code has the feed rate in it but for some reason the value my machine is using is 4, this would be fine if I use ipm but 4mm pm is to slow I have looked in the code for both buttons and they look fine it seems to use the feed rate that is in DRO 818, even if I change this it still grabs a 4 from somewhere, it changes the feed rate back in the setting screen back to 4 ever time I run the script,
Any other ideas why this is happening?
Re: Mach 3 Blue screen probing
« Reply #4 on: December 30, 2012, 10:34:29 AM »
it has to be in the button scripts, maybe try pasting one of them?
John

Offline ger21

*
  • *
  •  6,204 6,204
    • View Profile
    • The CNC Woodworker
Re: Mach 3 Blue screen probing
« Reply #5 on: December 30, 2012, 12:52:34 PM »
I looked at the X- button and it has an F4 in it.

   CurrentFeed = GetOemDRO(818)    'Get the current feedrate to return to later
   Code "F4"

Change the 4 to whatever you want it to be.

Note that you'll need to edit the code in each probing button.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3 Blue screen probing
« Reply #6 on: December 30, 2012, 03:13:36 PM »
Gerry,
Your a star, works now just fine, the dumb ass this end was looking at the code for the wrong button, thanks again. Once more this forum has got me out the poo.
Many thanks to all who replied, and a happy new year to you all
Regards, Paul.