Hello Guest it is July 05, 2020, 11:47:03 PM

Author Topic: Lost  (Read 2770 times)

0 Members and 1 Guest are viewing this topic.

Lost
« on: December 18, 2012, 03:03:34 PM »
Ok, I have my table set up.  it is 33x58.75 (inches).  i set all of my soft limits up.  0-33, 0-58.75.  everything works setting wise.  now, i am creating my project is vcarve, with the center of the work piece as my origin.  i want to also center my work piece on my table.  how do i do that in mach 3?  everytime i set it up in the center, it tells me i am out side my software limits?? i want to see the table on my display with my project in the middle.  it shows the table and the project in the lower left of the table.

help??

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Lost
« Reply #1 on: December 18, 2012, 03:54:02 PM »
Just jog to where you want the Zero position to be then press the Zero button at the side of each axis DRO. You have just created a work offset when you do that.
Hood
Re: Lost
« Reply #2 on: December 18, 2012, 03:59:52 PM »
i tried that it didnt work.  i will try it again. if it doesnt work can i call you?

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Lost
« Reply #3 on: December 18, 2012, 04:01:30 PM »
You may need to press the Regen button to regenerate the toolpath view.
Hood
Re: Lost
« Reply #4 on: December 18, 2012, 04:05:52 PM »
didnt work.  it says outside software limits

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Lost
« Reply #5 on: December 18, 2012, 04:07:53 PM »
Attach your xml and code and I will have a look.
Hood
Re: Lost
« Reply #6 on: December 18, 2012, 04:16:23 PM »
it wont let me upload.

i get this error "Sorry! There is already an attachment with the same filename as the one you tried to upload. Please rename the file and try again. "

Offline RICH

*
  • *
  •  7,410 7,410
    • View Profile
Re: Lost
« Reply #7 on: December 18, 2012, 05:04:02 PM »
Link about using soft limits without switches:

http://www.machsupport.com/forum/index.php/topic,11409.msg72346.html#msg72346

You can turn soft limits off. Just put the piece in the middle of the table, jog to center the piece, ref all, zero each axis, the dro's will go to zero,there is no offset created.

I don't have switches and don't even bother using soft limits without switches since if you home and then accidently bump / nove the the  axis with the machine off your not where you think you are relative to machine coordinates when you start up again.

RICH

Offline RICH

*
  • *
  •  7,410 7,410
    • View Profile
Re: Lost
« Reply #8 on: December 18, 2012, 06:21:35 PM »
Try posting the xml again but this time change the xml name to someting unique.
IE;    LOST_RGCUSTOM.XML

It is so much easier to review the xml and send you a modified one back with changed settings which
take care of any problems found.

RICH