Hello Guest it is December 11, 2019, 07:37:08 PM

Author Topic: Feed Hold G83  (Read 3065 times)

0 Members and 1 Guest are viewing this topic.

Feed Hold G83
« on: December 14, 2012, 02:02:51 AM »
Well here is another feed hold issue I seem to be having. This one is more of an annoyance. I'm not able to feed hold in the middle of a G83. Once Mach gets in the canned cycled it just continues until its done or I hit stop. Feed hold does nothing. I don't really care for working like this since some times I need to clear chips that have gotten waded up on the drill.

Didn't find any post here or in the yahoo group that had an answer to this. I would really like to be able to feed hold in the middle of a peck cycle.

My system
Mach3 (.66) lock-down version
ESS with latest lock-down plugin (10hd2)
PMDX-126
PMDX-107

Is this something that I'm just going to have to live with or is there a fix for this?

Thanks
   -Wes
-Wes

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Feed Hold G83
« Reply #1 on: December 14, 2012, 06:07:40 AM »
I use my FRO pot rather than feedhold so have never noticed it but there is definitely a problem. At first I didnt see it but it is only after the first hole has been bored that it doesnt work. Is that the same for you?
 I will mention it to Brian.

Hood

Offline Dan13

*
  •  1,244 1,244
    • View Profile
    • DY Engineering
Re: Feed Hold G83
« Reply #2 on: December 14, 2012, 09:11:22 AM »
I reported this to Brian about a year ago on the Yahoo group (was also broken when I was in G41/G42 mode) and it's been worked on by him. It did get fixed a few versions back (3.043.057 as per the change log), but I still see it here now and again (ver 062 here), but not sure why sometimes it works and other not. I did notice that it goes hand in hand with another problem where the toolpath window doesn't highlight the cut path. These both appear or disappear together. And it can happen in the same session with the same gcode - one part it runs OK, then the next it doesn't.

Dan
Re: Feed Hold G83
« Reply #3 on: December 14, 2012, 08:19:15 PM »
I use my FRO pot rather than feedhold so have never noticed it but there is definitely a problem. At first I didnt see it but it is only after the first hole has been bored that it doesnt work. Is that the same for you?
 I will mention it to Brian.

Hood

It does it any time I feed hold while in an arc move. I first noticed it when I was helixing some counter bores and then again when I was profiling the part.

Is there a place we can download the older versions? I didn't see anything on the Mach3 website.
-Wes

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Feed Hold G83
« Reply #4 on: December 14, 2012, 09:24:07 PM »
There is a way around the G83 feedhold problem.  Add  G4P0 in between each move. Mach will then use feedhold and stop on command. NOW you will NOT be able to jog away or do anything but maybe clear some chips or strings away and then continue on

G83 X0 Y0 Z-.5 Q.050 R1 F10
G4P0
X1
G4p0
X2
G4p0
X3
G80
M30

Feedholding on ARCs is just another can of worms . It is just ugly.

(;-) TP

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Feed Hold G83
« Reply #5 on: December 14, 2012, 09:32:39 PM »
That is with V.067. I see what is wrong on the arc FH but have not worked out a stable resolution for it YET. I am testing with helix's the worst of all arcs (;-) in mach3.

(;-) TP

Re: Feed Hold G83
« Reply #6 on: December 14, 2012, 10:29:21 PM »
Oops I posted my last reply in the wrong thread. Anyway I will try and start using FRO instead for now.

To answer your question it does it on any hole that is a G83
-Wes

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Feed Hold G83
« Reply #7 on: December 14, 2012, 10:30:31 PM »
OK here is the secret handshake for Feedhold on an arc. You press feedhold and wait until it stops. Then press stop. To restart use run from here, on the prep move MAKE SURE the rapid height is ABOVE your part or else you will crash your part.

Then press cycle start to return to the start of the arc and continue. SO FAR it has worked every time here to properly restart deep in a helix(worse case senario) mid arc.

NOW resist the urge to simply Cycle start after the feed hold (;-) The stopping is not the problem RESTARTING IS you will crash your part when MAch just wonders off in the field.

Just a thought, (;-) TP