Hello Guest it is May 25, 2019, 12:14:18 PM

Author Topic: THC problems  (Read 2423 times)

0 Members and 1 Guest are viewing this topic.

THC problems
« on: December 13, 2012, 05:39:52 PM »
I have never got my thc to work and i think i have tried everything possible.
Here is what it does, it shows the actual cut voltage but doesn't move the torch when the voltage changes and sometimes it will all of a sudden move it up but wont move it back down.
I was told i might have a port conflict but cant find out much info, i did find this but have to idea what it means. I am using candcnc electronics.
« Last Edit: December 13, 2012, 05:42:42 PM by wickedinhere »
Re: THC problems
« Reply #1 on: December 15, 2012, 08:58:27 AM »
Have you tried calling CandCNC?
Re: THC problems
« Reply #2 on: February 17, 2013, 06:34:01 AM »
I have a a problem with my thc - using cncdirect product. And hypertherm powermax 45.

Firstly it refuses to signal anything on parallel port 2. I need port 1 to drive motors. I've tested it on port 1 and eventually got it to signal.

However I cannot fire torch from Mach. Don't here relay even clicking albeit output 1 led signal in diagnostics. When I put multimeter across torch on - thc card - it fires plasma. It's almost as if relay does not get power from the signal. Any ideas I could get it to work?
I have called and been to supplier and he has tested it - came back saying all thc boards in good order. So I'm baffled because it on thc display panel it lights up on torch on - no relay click though and lights led in Mach diagnostics. What could be wrong?
for those who have the cncdirect thc product - with hypertherm setup. I found a connection error in supplier manual between torch connection and arc transfer connection. Green and black from Cnc interface cable  is the torch connection and not the red and black. Just so you aware.

I am not very clued up with electronics - more on the engineering/fabrication side, thus if any could offer me advice on testing relays on that board, I'd appreciated. How would I know power reaching relay?

Also kindly explain the process regarding arc ok signal if it has any effect on torch firing perhaps? With regards to delay etc.

Thanks in advance.

Re: THC problems
« Reply #3 on: February 17, 2013, 10:29:07 AM »
AcrOK will not effect the torch firing, but it will prevent movement if there is no signal present.  In order to fire the torch, you need to drive a normally open relay from whatever output you are using on your BOB, then connect the THC torch on eds to the relay.

Can't the guy you bought the THC from help you with the Mach3 setup?
Re: THC problems
« Reply #4 on: February 17, 2013, 11:03:54 AM »
Thx kindly

I've been to him to test the board and he says it's working fine. Also the config in Mach according to his manual is setup. Mach diag signals output1 but just don't click that relay. So I'm confused. It's been a month of battling with this and so frustrated that I'm planning to remove the unit completely. First the connection diagram had an error - showed torch wires to connect to arc ok and arc ok to torch. After Jim Colt sent me info, I managed to figure it out. I'm wondering if that could have caused a relay failure.

Should I get that relay checked out as second opinion?

Re: THC problems
« Reply #5 on: February 17, 2013, 04:13:52 PM »
If everything in Mach3 is correct then the wiring to the relay is wrong or the relay is bad.  Is the relay built into a BOB or is it separate?  What are you using for a BOB?  If the realy is built into the BOB then it's most likely a pin assignment issue.

Regarding the Hypertherm interface cable, Green/Black = Torch on/off, Red/Black = ArcOK, White/Black = Divided arc voltage.  We've had a number of interface cables come in recently that were wired wrong and had to remove the pins and put them in the correct place.
Re: THC problems
« Reply #6 on: February 17, 2013, 04:39:56 PM »
Hi

The BOB has 2 built in relays.

Re hypertherm cable - I've checked that to be sure and it's correct. In fact I discovered the wrong connection between arc ok and torch on  - thc - I got fault light and temp light flicker on plasma. When I checked Manual and contact Jim Colt for advice he sent me info which made it clear and solved the fault light issue by swapping those 2 connections around.