Author Topic: Need help with a custom script, disable a motor?  (Read 1544 times)

0 Members and 1 Guest are viewing this topic.

Offline jgsturbo

  • Active Member
  • Posts: 24
    • View Profile
Need help with a custom script, disable a motor?
« on: December 06, 2012, 01:13:06 AM »
I can't seem to find a command to disable a single axis charge pump.
I need to allow a single axis to be moved during a operation (tracked by an encoder) then re-enabled and its position update from the reading on the encoder DRO.

Any suggestions? Using a Gecko G540. The speed of the moving operation isn't really predictable either.

Offline BR549

  • Mach4 Alpha
  • Posts: 6,855
    • View Profile
Re: Need help with a custom script, disable a motor?
« Reply #1 on: December 06, 2012, 01:02:05 PM »
Can you expand on your Function a little more(;-).

(;-) TP

Offline jgsturbo

  • Active Member
  • Posts: 24
    • View Profile
Re: Need help with a custom script, disable a motor?
« Reply #2 on: December 07, 2012, 09:38:01 PM »
The carriage will need to move with a draw type tube bender and it will move at what ever speed pressure vs. the tube bending carries it. Then an encoder will re-establish the carriage location.

Basically I want to disable/re-enable the charge pump on one axis...

Offline BR549

  • Mach4 Alpha
  • Posts: 6,855
    • View Profile
Re: Need help with a custom script, disable a motor?
« Reply #3 on: December 07, 2012, 09:57:51 PM »
The charge pump is NOT a process that is axis specific it is either ON or off for everything at the BOB level.  You could rewire the G540 and have individual ENABLE inputs  to turn the drive on /off.

Still don't have a clear picture as to what you actually want based on your descriptions.

(;-) TP