Hello Guest it is November 19, 2019, 03:59:33 PM

Author Topic: Setup for homing X and Z but not Y  (Read 3860 times)

0 Members and 1 Guest are viewing this topic.

Re: Setup for homing X and Z but not Y
« Reply #10 on: December 07, 2012, 11:42:11 AM »
Here is the XML

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Setup for homing X and Z but not Y
« Reply #11 on: December 07, 2012, 01:45:04 PM »
Ok I see you are using the ESS, so possibly that may have a bearing on your problems. Unfortunately I dont have a ESS here at home so I cant test out until tomorrow to see if it is a problem with it.
In the mean time maybe  go to Ports and Pins, Inputs and set Y Home to port 0 pin 0 and restart Mach and see if it makes a difference. The

Hood
Re: Setup for homing X and Z but not Y
« Reply #12 on: December 11, 2012, 01:02:10 AM »
Y is set to pin 0 port 0, no change.  :(

Do you think it has something to do with the ESS? I keep thinking it has to be something simple but I can't find it.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Setup for homing X and Z but not Y
« Reply #13 on: December 11, 2012, 03:18:18 AM »
I dont see anything wrong with your xml so it should work fine. I only have a ESS on the big lathe but I dont have any home switches connected to Mach as I have them direct to my servo drives and do the homing in the drives, so it is hard for me to test with one home enabled and another not.
Might be worth an email to greg attaching your xml and see if he can find the problem, might even be worth trying an earlier plugin version if you can.
Hood