Hello Guest it is November 13, 2019, 10:08:55 AM

Author Topic: Setup for homing X and Z but not Y  (Read 3845 times)

0 Members and 1 Guest are viewing this topic.

Setup for homing X and Z but not Y
« on: December 05, 2012, 12:20:02 PM »
Hello,

I have a custom cnc machine that pulls long lengths of material through it as it cuts. It uses X Y & Z axis with the y axis being the infinite axis that pulls material through. I just installed home switches on the X and Z axis. Y has no home. When I click Ref All Home, the Z homes but nothing else happens. The home switches show up on the diagnostics screen correctly when actuated.

I was wondering if the Y has to be homed before the X and that is why it never gets to homing the X axis. I have tried setting the Y axis as a virtual switch and setting Y's switch to active low but nothing has made a difference. I have looked for settings that might be selected on the General config and homing and limits screens but I can't see anything relevant that I haven't tried already.

I am using Mach version R3.043.067

Thanks
ShapeShaver
Re: Setup for homing X and Z but not Y
« Reply #1 on: December 05, 2012, 01:16:56 PM »
Are you sure you have the Y homing Disabled ? If so, it should be ignored.
Re: Setup for homing X and Z but not Y
« Reply #2 on: December 06, 2012, 09:55:50 AM »
I'm not sure how to disable homing on only one axis. I have no inputs checked off or activated for the Y axis in the ports and pins "inputs" settings page if that's what you mean. I only have the home switches activated for the X and Z axis.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Setup for homing X and Z but not Y
« Reply #3 on: December 06, 2012, 10:28:53 AM »
Does the LED at the side of the Z go green when you home?
Hood
Re: Setup for homing X and Z but not Y
« Reply #4 on: December 06, 2012, 10:56:30 AM »
  I have a custom cnc machine ..........

Is it a CUSTOM screen set as well ? ? ? or the Standard MACH screen ?

Re: Setup for homing X and Z but not Y
« Reply #5 on: December 06, 2012, 10:04:22 PM »
OK, here is a DUMB ASS cobblers way around this. My machine homes in Z first. it looks for the switch to set the backs off until switch is unset.
The switch set and then unset is IMPORTANT. Mach3 is expecting the change.
My machine then homes Y axis, IF you don't care where Y axis home is then assign a switch to it and when it is trying to find home, trip the switch, after it reverses to untrip the switch manually untrip the switch. (let go!)
It will think Y is homed and proceed to home Z axis.
Any switch that can be easily reached by the operator can be used. I suggest to use the x-axis switch again.
Mach 3 allows ALL LIMIT switches and homing switches to be the same input. And that is what I do. so, if I trip any limit switch when it is homing in any axis, Mach3 thinks it has reached home and reverses the axis drive until the switch unsets.
Is this the BEST SOLUTION. I'm sure NOT. but it will work for now. Just make sure you config a home switch for Y. like you nhave foe X and Z.
so Mach 3 has something to look for and find when you trip it manually.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Setup for homing X and Z but not Y
« Reply #6 on: December 06, 2012, 11:23:42 PM »
YOu may want to take a look at the code in the REF HOME button.

(;-) TP

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Setup for homing X and Z but not Y
« Reply #7 on: December 07, 2012, 03:49:53 AM »
strong6515

Making sure you do not have the Home switch enabled in Ports and Pins, Inputs for any axis you do not have a home switch on should work fine. What would happen, if say no Y home switch, would be Mach homes Z sees switch and backs off, it then sees no home assigned for Y so it just sets home where it is without moving the axis and then moves onto the next axis in line. If the next axis has a switch enabled then it will move it, if it doesnt then it will just be set to home without moving.
Hood
Re: Setup for homing X and Z but not Y
« Reply #8 on: December 07, 2012, 10:29:12 AM »
Hood - Yes the Z goes green after it homes.

Overloaded - I am using the standard Mach four axis screen set, nothing customized.

strong6515 - I can try that quickly. But if it works then I would say this is a bug in Mach.

BR549 - How do I do that? Is that accessed through the screen designer?



Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Setup for homing X and Z but not Y
« Reply #9 on: December 07, 2012, 10:39:05 AM »
Attach your xml please and I will have a look.
Its unlikely  a bug in Mach as you shouldnt have to do that and I have never heard anyone else saying they have to so more likely a config issue.
Hood.