Hello Guest it is November 30, 2021, 10:05:12 PM

Author Topic: Homann Modio config error  (Read 17776 times)

0 Members and 1 Guest are viewing this topic.

Re: Homann Modio config error
« Reply #10 on: June 02, 2014, 11:15:30 AM »
I have a LCD screen, after initial DAL1H2Hp..........  It just shows "Cont Jog" at Top LHS
Re: Homann Modio config error
« Reply #11 on: June 02, 2014, 06:37:19 PM »
Peter,

Config registers look ok.

Can you disconnect the serial cable from the ModIO, that way Mach3 won't overwrite the LCD display.

Can you also disconnect all the inputs from the ModIO. If it is convenient, just remove the terminal block off the pin strip.

Using a jumper wire, can you now short each input to the GND pin on the ModIO.

On the LCD, you should see the state of each input . It should change as you short it to the GND pin. Can you do this for each of the inputs in turn, and let me know what you observe?

Cheers,

Peter

----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #12 on: June 03, 2014, 04:02:41 AM »
Peter,
Away from machine today will do as requested tonight.
However further investigation yesterday, got LCD back to status display, disabled brains.   The three A-D read ok and the MPG and switches change the values.

Will do the same in isolated mode and record the detail of the display.

Thanks for all the help.  HEX switch on 0, but could the core code be not the default,  Reading the pins but doing the wrong maths?   ( what I don't understand from the manual is if a new configuration is loaded how where is that stored, such that 0 is not over written. I assume Hex switch should be set to a vacant position and that loaded and reset. Seen no notes on this, at this stage have enough layers off the onion  and the default should do just fine for the controls I have.)

Peter
Re: Homann Modio config error
« Reply #13 on: June 03, 2014, 05:02:08 PM »
Peter,
Just Power and LCD connected.

I= 00
then short D in 0 reads 01, short Din 1 reads 02, short Din 2 reads 04, short Din 3 reads 08
Short Din 4 reads 10, short Din 5 reads 20, short Din 6 reads 40, short Din7 reads 80.

Further to this short a pair of pins and displays the sum. Also Short An1, 2 or 3 and reads 0000 on corresponding display

What next?

Regards Peter
Re: Homann Modio config error
« Reply #14 on: June 03, 2014, 05:36:52 PM »
Hi Peter,

That test shows that the discrete inputs are working correctly.

If you now connect the two MPGs to the ModIO. You should see each of  the MPG counters on the ModIO LCD display count up and down as you turn the MPGs.

Let me know what you find?

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #15 on: June 04, 2014, 04:53:22 AM »
Peter,
Input strip plugged back on.
Rotating, slowly the MPGs, one at a time it is possibly to see four state, Corresponding to the LEDs of the MPG signal reflected in the most significant digit, first digit, of I= display. eg 30, 70, B0, F0
And C0, D0, E0 F0

Information/state  ok at input just not there at 1155

S1 also works for input from one of the MPGs

Regards Peter
Re: Homann Modio config error
« Reply #16 on: June 04, 2014, 05:39:45 AM »
And what about the MPG counter on the LCD display for MPG2? It is on the 4th row on the LCD at the bottom right.

Can you confirm that your 2nd MPG is connected to inputs 1&2

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #17 on: June 04, 2014, 07:34:15 AM »
Peter,
EUREKA

I am there.  By pins 1 and 2 you mean physical connections pins 7 and 8  DIn 0 and DIn 1   !!!!!!!!

By which 2: then reads a value, Bottom RHS of LCD
 and on connection to PC/Mach3, tab to MPG & Brain turned on etc  MPG2 works, Thanks.

Where have I missed this as a set-up? since manual give MPG2pin as different?
Does this mean I can run Digispeed AND both MPGs since now not pin contention ?

Happy bunny !!!!
Thanks again.

Regards
Re: Homann Modio config error
« Reply #18 on: June 04, 2014, 08:01:17 AM »
Good to see its working now.

Yes you can also drive a DigiSpeed. You will need to switch the Hex switch off the 0 position. Initially switch it to the 6 position, reset the ModIO and check the comms setting on the ModIO display.

Peter

----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #19 on: June 04, 2014, 08:25:45 AM »
Peter
Where do I find, or is it ask, additional info, like on the other settings for this board?

I think the capability of this card is great, so don't keep it hidden please, publish more documentation.  What do the other switch positions enable?

Will order another to put on the mill also, when I have finished the rest of the Lathe.

Best Regards Peter