Hello Guest it is December 07, 2021, 05:16:29 PM

Author Topic: Homann Modio config error  (Read 17794 times)

0 Members and 1 Guest are viewing this topic.

Homann Modio config error
« on: December 03, 2012, 10:15:58 AM »
My new Modio throws up a 'an unsupported operation was attempted' error box when I go to CONFIG plugins and config modio hardware. I am using slave address 1, have checked use modbus plugin under ports and pins and have resarted Mach 3 and PC.
I can see the new type config box under setup serial modbus and it accepts the modbus variables I set ie port 1 and slave 1.
I have triedgoing back to non-modbus plugin. The board lights flash and modbus test works. I am on a John Prentice plugin ver 2.1a Aug 2007.

Any ideas?

Mike mike@pmuk.com
Re: Homann Modio config error
« Reply #1 on: December 04, 2012, 02:40:48 AM »
Hi Mike,

As I explained in my email to you the other day, the plug is a contribution that is no longer supported by John. There appears to have been a change in Mach3 since the plugin was written that is causing the error.

I suggest that you use the Mach3 Brains to communicate with the ModIO. Every thing that the Plugin can do can be done by Mach3 Brains

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #2 on: December 08, 2012, 08:19:52 PM »
Peter
After a long discussion with john prentice i discovered the plugin was not supported. Shame his videos are still up though!,, very hard to know it does not work when current info is there.

If I use the non serial plugin set from ports and pins and have both mpg1&2 ticked on the setup serial modbus screen and under the Homann config box I can get mpg 1to work but not 2. Can I actually use 2 mpgs with mach3 turning? Does it get y and z confused assuming the second mpg is connected to the y axis. I can test modbus and see tHe register 0 for address 1150 filling as I rotate mpg1 but where does mpg 2 enter. I read it is 1155 is that correct? Can I use brains in this. Mode?. In this mode my analogues don't work despite having a vb script  set to inputs 64 65 66. The lights dim under diagnostics as I turn pots but what else should I set?

If I tick serial modbus plugin under ports and pins I can set up the config 0,1 etc and now the brain works and I can use it to get mpg1 working fine but am unclear what to set in the brain for mpg2 to work
In the brain editing setup I tick the serial plugin enabled modbus as an my type of input, I get mpg tick count with M6P0 and mpg 1 with m0p0 but what set up should i use for mpg2. I seem to get some but a funny backwardsand forwards motion by using config0 modbus address 7. Is this right or what should I set?

Re: Homann Modio config error
« Reply #3 on: December 10, 2012, 02:59:11 AM »
Mike,

Section 6.3 of the ModIO manual depicts the ModIO register addresses. To use both MPGs you need to be concerned with registers,
1150 - MPG1 Count
1155 - MPG2 Count
1156 - MPG Tick counter

In the Mogbus serial plugin configuration page, you need to set up a Modbus transaction that reads these 3 registers. The most efficient way to do this is to read 7 contiguous holding registers starting at register 1150. Read theses at a 25mS period  rate.


Then in the Brain you need to;
1. get register 1150 (ENCODER1) and assign it to the Mach3 MPG1 count
2. get register 1155 (ENCODER2) and assign it to the Mach3 MPG2 count
3. get register 1156 (TICKCTR) and assign it to the Mach3 Tick count

In the brain, since you are reading 7 registers starting at address 1150, assuming you are using config 0 in the plugin
address 1150 is accessed as MOD:0-P:0
address 1155 is accessed as MOD:0-P:5
address 1156 is accessed as MOD:0-P:6

If this is not clear, look at the videos on setting up the Modbus serial plugin configs.

Also read through the article I wrote on using the ModIO with Brains and the serial Modbus plugin.
http://www.homanndesigns.com/pdfs/Using_Modbus_with_Mach3.pdf

The Brain needs to set;
address 1150 (MOD:0-P:0) to Mach3 Control variable 'MPG1 Count'
address 1155 (MOD:0-P:5) to Mach3 Control variable 'MPG2 Count'
address 1156 (MOD:0-P:6) to Mach3 Control variable 'MPG TickCount'

With it setup you should be able to see the MPG1&2 counts on the Mach3 diagnostic page change as you rorate the MPGs.

Also you need to use the Mach3 jog tab (accessed by pushing the tab key) to assign MPG1 to the X-axis and MPG2 to the Z-Axis, or visa versa.

Cheers,

Peter


« Last Edit: December 10, 2012, 03:01:48 AM by Peter Homann »
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #4 on: May 31, 2014, 03:36:52 PM »
Peter,
Mike gave Up on the Lathe and I now own it, long story.

Now wish to finish the conversion. 
 Your comments above very useful and spent last 48Hrs on a step learning curve of Brain and Modio, having just used vanilla Mach3 for the last 8? years
Register 1155 appears to give no valid outputs. The MPG works, the LEDs work but reading the register from the test shows a fixed value, normally 0000 or FFFF so assume the chip is partially fried?  A quick check proves most of the other pins are OK. Is there any other possibility?  If not I assume it is buy a new board or live without a second MPG?

Regards Peter
Re: Homann Modio config error
« Reply #5 on: June 02, 2014, 06:45:09 AM »
Hi Peter,

If you have a ModIO LCD, the LED will show you the state of the MPGs and the 8 discrete inputs.

Also ensure that the MPGs are connected to inputs 1&2 and 7&8

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #6 on: June 02, 2014, 10:14:43 AM »
Peter,

I am on the right pins at the Modio card end  12,13,14,15 for MPG1 and MPG2

Register 1155 does not change to MPG2 being moved.
Re: Homann Modio config error
« Reply #7 on: June 02, 2014, 10:26:35 AM »
Hi Peter,

Does register 1151 reflect the state of the 8 inputs pins as they are changed?

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #8 on: June 02, 2014, 10:30:50 AM »
Also can you do a screen grab of the contents of 8 registers starting at register 100 hex?

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Homann Modio config error
« Reply #9 on: June 02, 2014, 11:11:28 AM »
Peter, third digit of 1151 changes with movement of either MPG

8 registers from 100Hex screen dump attached

Regards