Hello Guest it is November 17, 2019, 07:43:34 PM

Author Topic: 4th Axis Addition!!!  (Read 5011 times)

0 Members and 1 Guest are viewing this topic.

4th Axis Addition!!!
« on: November 26, 2012, 10:25:32 PM »
Mach Community,

I am hoping that once again you guys can provide some input and advice for me!!!!  The winter time is upon us and I am finally starting to get some time to get back out in the shop and get back after it.  Some of you have probably read or even commented on some of my previous posts.  Although I had no intentions of ever cutting gunstocks, that's how things just ended up!!!  Now to add some personalized touches on the guns we are doing my gunsmithing buddy has approached me about doing some engraving on the barrels.  Although I am somewhat skeptical about chucking up a barrel that has hours of work in it, I have decided to give it a whirl.  At this point in time the software I have is fully capable of 4th axis engraving although I am not sure how capable I am!!!!  The main problem I have is the machine.  When I built router I wasn't certain if it would ever be functional.  I felt very good about the mechanical aspect, but wasn't to certain on the electrical.  I bought a 4 axis kit from Keling and rough wired to the computer to make sure it would work before I ever started the build.  Once I had movement, I then proceeded with the rest of the build. By the time I slaved the y axis for dual drive on the gantry, added home switches for each axis, and added the estop circuit and limit switches, I had consumed my C10 Bob.  My question is,  is there a usb bob that I could get for driving the 4th axis only?  My machine runs great now without any issues.  I am a little weary of completely upgrading to a new bob for the 4th axis when it will only be used occasionally.  My plan is to add the fourth axis and tailstock to a plate that I will bolt on when I need it.  Any input or advice would be greatly appreciated.

Thanks,

Jamie
Re: 4th Axis Addition!!!
« Reply #1 on: November 26, 2012, 10:40:27 PM »
have you considered adding another port and a bob just for the 4th axis, and any additional toys you might want to add?

John

Offline Tweakie.CNC

*
  • *
  •  8,000 8,000
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: 4th Axis Addition!!!
« Reply #2 on: November 27, 2012, 06:14:22 AM »
Hi Jamie,

If it's any help, I have already done just as John has mentioned and fitted an additional PCI Parallel Port card to my machine PC.
This is used for my forth axis (and all the other silly stuff I do without affecting my existing setup, machine wiring etc).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
4th Axis Addition!!!
« Reply #3 on: November 27, 2012, 08:51:24 AM »
Are your limit switches sharing 1 pin or does each axis have its own pin? I wouldn't think using the PP and USB at the same time would be synchronized correctly.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: 4th Axis Addition!!!
« Reply #4 on: November 27, 2012, 07:57:16 PM »
Thanks for the info so far.  Sounds like I need to just add another port.  I built my computer, so I had to add a parallel port card to it because there wasn't one on the motherboard.  I have a PCI express slot available or I can get this one.



http://www.newegg.com/Product/Product.aspx?Item=N82E16812196220
Anyone used one of these?  It will plug right into to the motherboard.

Also check this out.  I can't even start to build one of these for this.


http://www.ebay.com/itm/160928043751

I may need some help get this new card address and set up.  Its been awhile since I done the original machine, so I am going to be a little rusty.  If I do it this way, I can clone my original machine setup.  Then I don't have to worry about screwing up my original setup and I can revert back to it if need be.  Thanks for all the help!!!  Your all top notch!!!!

Thanks,

Jamie
Re: 4th Axis Addition!!!
« Reply #5 on: December 15, 2012, 06:05:03 PM »
Guys,

Just thought I would follow up.  I took everyones advice and bought another breakout board and parallel port.  I have finally finished all of the Christmas gifts that my wife requested!!!!  The Vectric software that I bought a year and a half ago is pretty good stuff.  No telling what I could do with it if I read the tutorials!!!! :D  Christmas gifts was the trade off for the purchase of the 4th axis.  It will be here Monday. ;)  I finally set down made backups and screen shots of everything.  I had to make some changes because one of my slaved axis was actually A.  Never thought I would use it at the time, but the cnc stuff seeems to be a sickness!!!!  Hopefully tomorrow I will get everything wired in and ready.  I've got a spare stepper and amp that I am going to test with.  Wish me Luck and thanks for everyone's help.

Jamie
Re: 4th Axis Addition!!!(More Help Needed!!!!)
« Reply #6 on: December 28, 2012, 06:00:23 PM »
Hey Guys,  Hope everyone had a good Christmas!!!!  Finally landed some time off work, so Ive been in the shop working.  Parallel port and additional bob has been added.  I have the 4th axis tuned and calibrated.  I thought I was making good progress until I tried to post some programs. ???  I have been reading 4th axis posts for the last several hours.  I think I have everything set up correctly, but obviously I have missed something.  I started out by doing a simple wrapped text program from Vcarve pro.  WOW!!!  This doesn't look right.  Unfortunately I am no G-code wizard so I have to rely on others for help occasionally.  Keep in mind this is the first wrapped toolpath that I posted.  I figured a picture is worth a thousand words so I have included some.  Also I have the G-code file.  It could be that I have botched something in Mach or the cam program. Possibly both!!!!  I feel like I have been drug behind a car!!!  I seem to have to learn everything the hard way.  My fourth axis is set up running parallel with the y axis.  Any help would be greatly appreciated!!!!

Thanks,

Jamie

Offline alenz

*
  •  137 137
    • View Profile
Re: 4th Axis Addition!!!
« Reply #7 on: December 28, 2012, 07:10:06 PM »
In Config>General Config>Rotational, check to see if ‘Rot 360 rollover’ is checked. If so un-check it.
That fixed it on my machine.
HTH,
Al
Re: 4th Axis Addition!!!
« Reply #8 on: December 28, 2012, 07:36:24 PM »
I'll give it a look. If memory serves me correctly it is. I'll check after dinner. Thanks
Re: 4th Axis Addition!!!
« Reply #9 on: December 28, 2012, 08:04:38 PM »
Al,

Made the change.  Here is what it looks like now.  I want to ask one more question.  I also program with Alibre Cam 2.0 Expert(Visualmill running inside Alibre).  The Vectric software never goes more than 360 on the A Axis.  Makes sense to me.  360 degrees in a circle.  I have a 4th axis program that I am going to attatch.  I used this package before on a Haas machine with a fourth axis.  I remember that the graduations were not in degrees.  I believe they were defined as linear.  What will I have to change in Mach to be able to program with it?  It is a pretty powerful package.  Take a look at the program and I am sure that some of you will be able to explain this to me.  Once again thanks for all of the help making this a success ;D