Hello Guest it is May 15, 2021, 12:58:48 AM

Author Topic: Dir pin pulsing in one direction, and stable in the other  (Read 3970 times)

0 Members and 1 Guest are viewing this topic.

Dir pin pulsing in one direction, and stable in the other
« on: January 25, 2007, 05:50:19 PM »
Tried to get stepper drive to work, and found it only runs in the + direction.
When looking at the signals with a scope, I see the step in pulse as is should be in both directions (+ and -)
However the dir pin is stable (low) in the + direction, and pulses in the - direction

Both pulse and dir are set to 15 micro seconds pulse


I bet I will feel silly.....

JB

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Dir pin pulsing in one direction, and stable in the other
« Reply #1 on: January 25, 2007, 09:30:13 PM »
Hi, JB

In Ports & Pins, Motor Outputs, Have you tryed setting the Dir Low Active to a check inst-ed of X or opposite state.

Some stepper controls are sensitive to leading / trailing edge state.

If you need to change the direction after you get it working, You can change it in Home & Limits, Reversed Box.

Hope this Helps, Chip
Re: Dir pin pulsing in one direction, and stable in the other
« Reply #2 on: January 26, 2007, 03:44:05 AM »
Hi Chip

Thanks for info, unfortunately I did not fully check what was going on.
so this morning I put both probes on the signals and found that
depending on the direction, either the step OR the dir pin pulses, the other stays stable.

I am confused now.
should the dir pin be stable either low or high depending on the direction while in motion. and only swap when a direction change happens ?
or do both pulse during motion?

JB
Re: Dir pin pulsing in one direction, and stable in the other
« Reply #3 on: January 26, 2007, 07:05:45 AM »
Make sure you do not have MaxNC checked in ports and pins. It will make both pins pulse when moving.

Darek
Re: Dir pin pulsing in one direction, and stable in the other
« Reply #4 on: January 26, 2007, 07:24:36 AM »
Think I checked for that....
Will do so again tonight just to be sure.

it is new hardware, so can't tell if it is the MB doing this or the software.
am also contemplating changing to other pins, just in case

Thanks
Re: Dir pin pulsing in one direction, and stable in the other
« Reply #5 on: January 26, 2007, 08:49:04 AM »
What at you running for hardware?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Dir pin pulsing in one direction, and stable in the other
« Reply #6 on: January 26, 2007, 11:33:45 AM »
Via Eden EPIA SP  1.3G
Runs pulse test fine, not as stable (10usec jitter) as I had hoped but hey it came cheap
XP prof with service packs
Nothing else installed, ran through all the MACH optimizations settings.
network switched off.
The lpt port on this board comes from a VT1211LPC IO chip, companion of the VT8237 south bridge.... if that helps
.
Incidentally has anybody run from a core duo ? yet, as I may be able to get my paws on that. It would be a Commell board


Thanks

JB


Re: Dir pin pulsing in one direction, and stable in the other
« Reply #7 on: January 26, 2007, 05:13:04 PM »
OK got it working now. as predicted feel a bit silly here

Got the 0V wire wrong on the DC header of the MB, so control logic was floating at 5v...
As soon as I stuck the scope on only it became clear that the signals where working OK, So wire inspection started...


All thanks for helping...