Hello Guest it is November 14, 2019, 09:10:59 PM

Author Topic: Mach3 Not Responding  (Read 5844 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Not Responding
« on: November 15, 2012, 11:55:55 AM »
Hi guys,
I receiving the error messagge below, when I open "Ports & Pins" and when I turn on the spindle with M3. ???

I use XP and the USB SmoothStepper.
To VFD I have the C32 (rev4.2) of the CNC4PC.

Can someone help me to solve this problem.

PS. When happen I need to Kill Mach3 with Task Manager, and disconnect the usb from PC.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Mach3 Not Responding
« Reply #1 on: November 15, 2012, 07:11:05 PM »
Motors produce a lot of electrical noise, motors with VFDs produce a whole lot of electrical noise. What is happening is that the noise from your VFD is killing the USB communication. First make sure everything is Earth grounded properly and that no high voltage cables (VFD, stepper motors, etc) are near the USB cable. Use as short of a USB cable as you can.
Happy machining , Jeff Birt
 
Re: Mach3 Not Responding
« Reply #2 on: November 16, 2012, 03:38:12 AM »
Thanks for your replay,
Could you explain more about Earth ground :"First make sure everything is Earth grounded properly".
In post a photo of my wiring.
I have to connect the usb GND's to the Earth contact?

Offline RICH

*
  • *
  •  7,370 7,370
    • View Profile
Re: Mach3 Not Responding
« Reply #3 on: November 16, 2012, 06:29:02 AM »

Offline MGC

*
  •  1 1
    • View Profile
Re: Mach3 Not Responding
« Reply #4 on: April 21, 2013, 10:38:55 AM »
i took a look at your image i recognized that you conected the y axis 2 drives parallel  i researched that before before buying the c32

you need to connect the second Y axis motor to another axis port in case of a 3 axis machine connect it to the 4th axis and from the mach3 settings
verify that axis as a slave to the Y axis you'll need to order an extra c34 for that