Hello Guest it is September 21, 2019, 12:08:48 PM

Author Topic: Mach3 and Tapmatic Tapping Head  (Read 22489 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 and Tapmatic Tapping Head
« Reply #60 on: November 01, 2012, 07:37:40 PM »
What make/model of BOB do you have?
If using a separate power supply then you will likely need to tie its 0V to a 0V on your breakout so that the signal is being referenced at the same potential .
4mm may be ok, try and see, you will soon know as when you spin fast you will not get an accurate reading if it is too small
Hood
Re: Mach3 and Tapmatic Tapping Head
« Reply #61 on: November 02, 2012, 03:29:32 AM »
ive no idea, ill phone angel tech later and double check with him, unless he replies here first.

« Last Edit: November 02, 2012, 03:33:30 AM by andy_con »
Re: Mach3 and Tapmatic Tapping Head
« Reply #62 on: November 02, 2012, 05:47:05 PM »
all wired up i think?

just not sure on how to set up ports and pins.

i believe im connected to input 12. so i activated input 12.

but im getting no reading still

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 and Tapmatic Tapping Head
« Reply #63 on: November 02, 2012, 05:51:45 PM »
You set the Index input to the port and pin number you have it connected to.
Hood
Re: Mach3 and Tapmatic Tapping Head
« Reply #64 on: November 03, 2012, 12:29:28 PM »
hood, is this a slow sensor or something?

got a 11mm wide slot and the highest rpm reading i can get is 1340

my machine goes up to 4000rpm

cheers

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 and Tapmatic Tapping Head
« Reply #65 on: November 03, 2012, 12:56:31 PM »
Have you remembered to set Index Debounce to Zero?
The sensor is plenty fast so shouldnt be an issue with that, the BOB may be a problem, could have slow optos on it?
Hood
Re: Mach3 and Tapmatic Tapping Head
« Reply #66 on: November 03, 2012, 01:06:59 PM »
the sensor is connected straight to the db25 connector, not to the BOB

debounce is at 0

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 and Tapmatic Tapping Head
« Reply #67 on: November 03, 2012, 01:11:31 PM »
Shouldnt be a problem then, can you attach your xml and I will take a look to see if there is an issue in it.
Hood
Re: Mach3 and Tapmatic Tapping Head
« Reply #68 on: November 03, 2012, 01:14:22 PM »
errr sure but ive not got a clue what your talking about lol

what file and where do i find it?

also i keep snapping taps, im using this code

m3 s1000

g00 x20 y0
g00 z3

G95
G1 Z-10 F0.5
G1 Z5
G94

m5
m30

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 and Tapmatic Tapping Head
« Reply #69 on: November 03, 2012, 01:20:04 PM »
The xml is in the main Mach3 folder and will have the name of the profile you are using followed by a xml file extension. You will need to copy it to your desktop then rename to attach to the forum, call it andy_con.xml and that should work.

You need to have a short rapid retract for that tapper, if I recall correctly, to engage the reverse clutch quickly.
Hood