Hello Guest it is March 06, 2021, 01:04:09 AM

Author Topic: Mach + Smoothstepper and Dwell  (Read 1927 times)

0 Members and 1 Guest are viewing this topic.

Mach + Smoothstepper and Dwell
« on: October 18, 2012, 09:46:01 AM »
I know that Dwell in milliseconds hadn't worked with the smoothstepper in some time.  I'm not sure it ever got fixed.

My question is, if Mach & Smooth stepper only supports Dwell in Seconds, then will fractions of a second not work?

G4 P0.5   This seems to be totally ignored and 1 second is way too long.

I'm doing tapping routines and I'm trying to fine tune the Dwell between the M4 and backing out of the hole. Anyone know a way around this?

(Mach 3.43.53)

Thanks,
Richard
Re: Mach + Smoothstepper and Dwell
« Reply #1 on: October 18, 2012, 10:04:23 AM »
Richard,

Must be a recent bug addition.  When I used a SmoothStepper, fractional delay values worked fine.  Try an older version of the plug-in (I think I last used v05ogx), and I think you'll find it works as it should.  I don't understand why the millisecond mode has never been fixed....

Regards,
Ray L.
Regards,
Ray L.
Re: Mach + Smoothstepper and Dwell
« Reply #2 on: October 18, 2012, 10:33:25 AM »
I hadn't had any luck with any dwells set less than 1 second.  I also noticed, when running on PP port, my spindle stops immediately at the end of the feed down depth and with the smoothstepper there is a delay so my tap extends much more than normal.  I guess this is due to the usb delays or the way the SS works. I know my VFD stops on a dime and reverses quickly, but when running G-Code it seems there is a delay between machine motion and the spindle.

Maybe I can put a slight underfeed in my Feed coming back up so the tapholder isn't stretched out so far when it comes out of the hole.

Richard

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach + Smoothstepper and Dwell
« Reply #3 on: October 19, 2012, 06:11:16 AM »
As far as I am aware the SS has never taken notice of the Dwell setting in General config and will always treat a dwell as seconds. I had thought I had remembered an option in the plugin for setting this but I just looked and dont see it so I must have been mistaken.
Hood