Hello Guest it is January 28, 2023, 05:45:59 AM

Author Topic: New ess install, can not get smooth stepper to write to XML  (Read 4321 times)

0 Members and 1 Guest are viewing this topic.

New ess install, can not get smooth stepper to write to XML
« on: October 06, 2012, 08:46:57 PM »
Back Ground: Old computer finally kicked the bucket (xp system with mach3 parallel port setup no ss, served me well for 6 years) Have new computer running win 7 32bit, installed new ess.

I have loaded the latest mach3 (066), and ess V10fb2 driver. ran through the normal setup and cannot get the plugin to right any changes to the XML file (when I restart mach3 it is like a fresh install). Checked for read only conditions on XML already.

Questions;

1.  Does the ESS hardware have to be installed and connected in order to write to the XML file?

2. When you make changes to the ss pugin config in mach3 does it actually write code in the xml or somewhere else?

3. Any suggestions ?

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: New ess install, can not get smooth stepper to write to XML
« Reply #1 on: October 06, 2012, 10:19:36 PM »
Suggestions:

1) Remove the 066 version of Mach and install 062, you can download it from my website or the Mach FTP site. I have had several customers have problems with 066 doing strange things.

2) Actually connect the ESS when trying to configure it. I believe the ESS plug-in will not write to the XML unless it was able to connect to the ESS and verify the settings you entered were correct.

In some cases your PC may lock a downloaded file and not let it be changed. You can right click on the file and see if that is the case.
Happy machining , Jeff Birt
 
Re: New ess install, can not get smooth stepper to write to XML
« Reply #2 on: October 06, 2012, 11:41:15 PM »
Thanks Jeff, I downloaded the (062) and will try tomorrow,
Re: New ess install, can not get smooth stepper to write to XML
« Reply #3 on: October 07, 2012, 09:07:32 PM »

It is working!!!!

Used mach ver 062, third of latest version of ESS driver. It did not save the changes to the XML at fiirst. Changed mp3 in mach3 to run as xp, when asked to use the default after entering the IP addrerss during the mach3 startup

 I said yes, the default loaded and I could save to the XML. I can make changes now with no problems, System is now cutting parts!


Thanks,

Frank

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: New ess install, can not get smooth stepper to write to XML
« Reply #4 on: October 07, 2012, 09:09:34 PM »
 :)
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!