Hello Guest it is January 29, 2020, 12:00:30 PM

Author Topic: another e stop question  (Read 3229 times)

0 Members and 1 Guest are viewing this topic.

another e stop question
« on: October 02, 2012, 05:19:15 PM »
I have my E stop set up so that my switches are wired in series and attached to Gnd and pin 10. I'm pulling 5 volts through a 10k resistor to pin 10 on a Xylotec board. If I set pin 10 in Mach 3 to "active low" the "reset" button won't work. If I set it to active High the reset button and the limit switches work but the problem is - if a limit switch is activated I can't use "limit overide" to move the machine off the switch. It would seem that they should be set to active low so that when the voltage is interrupted they should go active and I should be able to reset them. Any ideas.

Thanks in advance for any imput you may have.
Dave

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: another e stop question
« Reply #1 on: October 03, 2012, 07:06:54 AM »
It is much better to put limits in as limits rather than E-Stop, as you have found both work a bit differently and if you have the limits wired with and set as E-Stop you will not be able to use the limit override.
Hood

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: another e stop question
« Reply #2 on: October 03, 2012, 09:36:36 AM »
From what I know, limit switches should not be connected to the same input pin as the E-Stop and axes with home switches should also be on separate input pins.

In my machine I have all limits / home for Y & A to one input pin, X & Z to another input pin, the E-Stop to another input pin, and the Auto Zero for the Z axis to another input pin.

To assure that all switches are assigned the correct pin I use the “Automated Setup of Inputs” from the Config Menu, Ports and Pins, Input Signals Tab. This way Mach sets all as needed and all work perfect.
Nicolas

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: another e stop question
« Reply #3 on: October 03, 2012, 09:52:36 AM »
Limits can be connected in series and can all share one input and Mach will be fine.You can share the Home switches with the limits if you wish. When homing one axis will move at a time and then the next etc. When not homing the switches will be seen as limits.
Obviously the way you have it set is also fine, just it uses more inputs and previously with the parallel port you were often short of inputs.
Hood

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: another e stop question
« Reply #4 on: October 03, 2012, 11:36:22 AM »
Good to know Hood

I thought Home switches should be on separate pins but now if I ever need a spare input pin I know what to do
Nicolas

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: another e stop question
« Reply #5 on: October 03, 2012, 01:24:05 PM »
They can be but dont have to be, there is no real advantage to having them seperate at the moment unless you wish the homes not to be at the extent of the axis.

Hood
Re: another e stop question
« Reply #6 on: October 03, 2012, 03:20:32 PM »
I guess I worded that wrong in my first post. I have a switch set up at both ends of each axis. These also act as my home switches. There is also a button wired in the same series that I call my E stop button. It is all one circuit. If I set pin 10 in Mach 3 to "active low" the "reset" button won't work. If I set it to active High the reset button and the limit switches work but the problem is - if a limit switch is activated I can't use "limit overide" to move the machine off the switch.

Thanks for the response.
Dave

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: another e stop question
« Reply #7 on: October 03, 2012, 03:26:48 PM »
What do you have set to pin 10 in Mach? Limits and Homes or E-Stop?
Hood
Re: another e stop question
« Reply #8 on: October 04, 2012, 05:47:40 AM »
Everything is set to pin 10
Re: another e stop question
« Reply #9 on: October 04, 2012, 12:59:27 PM »
Hood,
You're a genius, your last question got me thinking. I couldn't disable the E stop in Mach, so what I did was assign it to an unused pin (11) and set it to active low. Now everything works exactly like it's supposed to. Thanks everyone for your responses.
Hood, Thanks for you help, and for asking the right question.
Dave