Hello Guest it is January 29, 2020, 09:09:12 AM

Author Topic: Mach3 loses home settings  (Read 3568 times)

0 Members and 1 Guest are viewing this topic.

Mach3 loses home settings
« on: September 27, 2012, 08:26:32 AM »
I have done the home settings on my machine a few times now. Problem is that the settings get lost as soon as i close mach3 or switches the pc off.
When i restart my machine or re-opens mach3, the home settings are gone. The machine takes the current position of the cutting head as the new home position. then i cannot jog past zero in the middle of the table. I was not sure in the beginning, but now i`m sure. What do i need to do to save the home settings position?

I followed the tutorial on the video section on setting up the home position, and all is working great, but beware on exiting mach3 or switching off the pc.
The other thing that confuses me : my table is 1480(x-axis)x890(y-azis) big. Do i set the softmin to "0" and the soft max to "1480" & "890" ? These settings are when the machine hits the switch and it opens up to stop the machine from moving past this point.

At this point my biggest concern is the machine losing its home position.

THX
Andre

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 loses home settings
« Reply #1 on: September 27, 2012, 01:31:32 PM »
Are you actually homing to switches or are you just telling Mach it is home?
Hood
Re: Mach3 loses home settings
« Reply #2 on: September 28, 2012, 01:48:35 AM »
I click the "ref ALL" button and the axis move all the way to the left and bottom of the machine. Sometimes i have to click the ref all button a few times . When the machine hits the switches , it moves of the switch , just as described by the manual/video. So i`m actually homing the machine.

I must be missing something again. I`l keep trying till i get it.

THX
A

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 loses home settings
« Reply #3 on: September 28, 2012, 02:56:55 AM »
Ok so not really sure what you are asking. When you start Mach you are meant to home. Are you meaning the offsets are not being stored?
If that is the case it is probably one of the options lower right of General Config page, most likely the last one which says Copy G54 from G539.253 on startup. You want that unchecked.
Hood