Hello Guest it is August 25, 2019, 06:03:56 AM

Author Topic: Steppers won't power up with Mach3  (Read 3329 times)

0 Members and 1 Guest are viewing this topic.

Steppers won't power up with Mach3
« on: September 20, 2012, 02:28:43 PM »
Running  Mach3 on an XP machine with a Soigeneris STDR-4C controller.

After my hard drive failure, I'm getting close to being back up and running. I've got Mach3 installed, SmoothStepper, and my macropump all in the right place.

When I start Mach3, my steppers don't power up. I get a message on Mach3 that says there's an external estop request or my limit switches are active. I'm sure my estop switch isn't activated, and the X,Y,& Z limit tabs aren't near any of the limit switches. Below is an image of the error message I get. Anybody seen this before?



I have clicked the button that says "fix it for me...", but that doesn't fix it for me.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Steppers won't power up with Mach3
« Reply #1 on: September 20, 2012, 02:50:08 PM »
Have a look on the diagnostiocs page and see if any limits are lit, could simply be you have them configured wrong or have the active state wrong.
Hood
Re: Steppers won't power up with Mach3
« Reply #2 on: September 20, 2012, 03:11:57 PM »
I don't see anything that says "limits" lit. The Emergency is lit. Would a limit switch problem keep the steppers from powering up? Here's a not-so-great image of my diagnostics window. I'm not sure what the 3 yellow lit "home" lights refer to.

In the past, with Mach3 running and my controller powered up, the steppers were powered up unless I hit the Panic EStop on the controller.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Steppers won't power up with Mach3
« Reply #3 on: September 20, 2012, 03:20:00 PM »
Your E-Stop LED is lit so it is that that is the problem, Either you have the active state of the E-Stop setting wrong , you have the pins set incorrectly , your wiring is wrong or your E-Stop button is pressed.
You do have the Home switches active so likely you have the active state for them set wrong.
Hood
Re: Steppers won't power up with Mach3
« Reply #4 on: September 20, 2012, 04:26:40 PM »
Your E-Stop LED is lit so it is that that is the problem, Either you have the active state of the E-Stop setting wrong , you have the pins set incorrectly , your wiring is wrong or your E-Stop button is pressed.
You do have the Home switches active so likely you have the active state for them set wrong.
Hood

I cycled my EStop button many times, and it isn't on. I even opened up the case to see if something was unplugged or broken. I didn't see anything. If I do press the EStop button, my controller powers down, so I think the switch is working correctly. I toggled the EStop active state, and nothing changed. I did notice that it toggled it's self back to how it was before I toggled it... I'm not sure why it did that... is that an xml file thing?

Is it possible that the xml file doesn't save all of the settings Mach3 needs for my controller and machine? If it doesn't, I guess I have to figure out what they need to be, all over again.

If I "correct" the error buy clicking the "fix it for me..." button, and I tell Mach3 to reference, the Z axis display on Mach3 increase indefinitely, as if I had an infinitely high Z axis, and it never gets to the limit switch.

I still wonder, if it's a limit switch problem, why the steppers don't even power up. When I first set up Mach3 with my controller, they powerd up, and I just had to get the Ports & Pins all set correctly for it to see the limit switches.
Re: Steppers won't power up with Mach3
« Reply #5 on: September 20, 2012, 05:42:12 PM »
Problem solved. There was an issue with SmoothStepper. It didn't install correctly. Jeff at Soigeneris figgured it out. Whew! I have 25 beer tap handles to route!

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Steppers won't power up with Mach3
« Reply #6 on: September 20, 2012, 06:18:21 PM »
:)