Hello Guest it is January 16, 2022, 02:10:42 PM

Author Topic: Mach not communicating with machine  (Read 1979 times)

0 Members and 1 Guest are viewing this topic.

Mach not communicating with machine
« on: September 05, 2012, 12:08:26 PM »
I've found several posts on this subject and read them but haven't been able to come up with an answer, all help would be appreciated.
I replaced my computer on my machine. It has a pci card for the parallel port. I've transferred the .xml files and screensets and I now have two issues (probably related to the same problem). The biggest issue is that Mach will not communicate with the machine. The second issue is that I can't reset the emergency stop unless I change it's setting to "Active Low". The only difference I've been able to come up with is that the old computer has LPT1 as the com port and the new computer has LPT3. I've changed the port number in the general config from 1 to 3 and left all other settings as the are on the old computer. If I put the old computer back on the machine everything works fine. The new computer gets no response. Any suggestions?
Thanks,
Dave
Re: Mach not communicating with machine
« Reply #1 on: September 05, 2012, 02:15:05 PM »
I found the problem with communication. I had the wrong port address in the ports and pins. I'm still having the problem with the E-stop. I can only get it to reset if I run "Active Low" and then my physical e-stops don't function.
Dave