Hello Guest it is September 21, 2019, 05:56:52 AM

Author Topic: mach/computer crashing maybe from electrical noise  (Read 1478 times)

0 Members and 1 Guest are viewing this topic.

mach/computer crashing maybe from electrical noise
« on: August 28, 2012, 05:37:27 PM »
Hi all,
I don't think this is a Mach specific problem, but figured this might be the best place to ask. Also tried searching for an answer to no avail.

I've got a Bridgeport BOSS8 that I have/am retrofitting. As part of this, I've mounted a computer and touch screen to the head where the original control panel was

to this


All seemed to be working, but I wasn't really using the machine, just jogging and a few minor manual cuts. A month ago, I had something to cut via gcode. The program starts and within the first 10-20 moves, mach freezes up. After shutting everything off, the computer recovers I could restart mach and try again and it would die again. So I eventually come to the conclusion that I mounted the computer incorrectly (the modified computer case was tack welded straight to a hinged metal "door" on the front of the mill. So, I lift off the hinged piece and computer/monitor assembly and set it on the bench 3 feet from the mill and all is good. Gcode runs fine. So simple solution right, isolate the computer from the front of the mill.

So the other night, I spend 2 hours making some delrin mounts to electrically isolate the computer assembly from the rest of the mill. But as you probably guessed, it didn't work.

So any ideas what might be the problem and how to solve? Is this more likely to be caused by EMF from the 3 phase motor or the vfd or the proximity of the computer to one or the other? Any ideas/possible solutions would be appreciated. I'd really hate to throw away all the work I've put into mounting the computer/monitor and even remaking/sculpting the fiberglass enclosure.

Thanks,
Chris

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: mach/computer crashing maybe from electrical noise
« Reply #1 on: August 29, 2012, 02:48:57 AM »
Most likely the VFD but to be sure it is spindle related and not axis can you run some code without the spindle?
Hood
Re: mach/computer crashing maybe from electrical noise
« Reply #2 on: September 06, 2012, 01:39:22 PM »
Hood, thanks for the reply.
I messed with it a bit, but need more time to really test. Will hopefully update soon.
Thanks again.
Chris