Hello Guest it is February 25, 2020, 12:41:50 AM

Author Topic: Whining stepper motors  (Read 6141 times)

0 Members and 1 Guest are viewing this topic.

Whining stepper motors
« on: August 17, 2012, 12:14:24 AM »
They drag,whine, and have a mind of their own. Would this be a driver problem or a motor problem?  Thanks.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Whining stepper motors
« Reply #1 on: August 17, 2012, 03:31:42 AM »
Possibly a tuning problem, ie you have the Velocity and/or acceleration set too high and thius you are stalling the steppers. Could even be you have the steps per unit set wrong.
Hood
Re: Whining stepper motors
« Reply #2 on: August 18, 2012, 11:49:19 AM »
Finally got them moving, but have to spin them manually (by hand) then they run fine. But no start from stop on the workbench disconnected from machine. Try to cut a circle and the machine cuts a square box even though Mach is showing it is cutting a circle. Thanks Hood. Going to order a new driver...
Re: Whining stepper motors
« Reply #3 on: August 19, 2012, 04:51:29 PM »
Now I am really confused whether it is the driver or not. cnc plasma and program to cut a 5 inch circle it whines and moans and cuts a 5 inch square. ???

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Whining stepper motors
« Reply #4 on: August 19, 2012, 05:02:28 PM »
When you say a square is it exactly 5 inch? If it is then sounds like you can only get motion on one axis at a time so does sound like a hardware issue. Are you sure its wired correctly and correct ports and pins assigned?
Hood
Re: Whining stepper motors
« Reply #5 on: August 19, 2012, 05:18:02 PM »
No, not exactly 5 inches. As a matter of fact it will cut any size square from the same program, like it has a mind of its own. But it cant cut a circle. LOL. Thanks Hood.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Whining stepper motors
« Reply #6 on: August 19, 2012, 05:21:12 PM »
Can you jog two axis at a time?
 If you zero the X and Y DROs then MDI G0X10Y10 does it do a diagonal move?
Hood
Re: Whining stepper motors
« Reply #7 on: August 19, 2012, 05:31:40 PM »
You cant jog one axis at a time..... if you tap x it will move barely,  but if you press x it wont......same with y......with z ( height) it goes down either way you try...

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Whining stepper motors
« Reply #8 on: August 19, 2012, 05:39:29 PM »
Your wiring sounds wrong or pin assinments in Mach.
Regarding the tap as opposed to pressing, that could be because you have Mach in Step Jog mode, press the Tab on your keyboard and see what Jog mode it is in.
Hood
Re: Whining stepper motors
« Reply #9 on: August 19, 2012, 06:18:22 PM »
I sent a snapshot somewhere lol