Hello Guest it is September 23, 2021, 10:08:10 AM

Author Topic: Another help request.  (Read 2061 times)

0 Members and 1 Guest are viewing this topic.

Another help request.
« on: August 13, 2012, 07:06:20 PM »
Yes, yet another help request.

I have a C10, Rev 8 parallel board. I am adding a SSR to Output pin 1 and GND.

When I test the C10 Output it tests 5.22 VDC on my multimeter and that is reaching the SSR, yet the SSR does NOT switch the device on/off.

Now, when I connect a 6VDC battery to the input of the SSR the device turns ON when connected and OFF when disconnected as it should.

I am missing something here. The Mach3 pin assignments are correct (pin 1) and when I press cycle start the line goes High (5.22 VDC) and reset goes low (0 VDC) but nothing happens with the SSR. I have tried this with a C8 card and a OPTI22 25amp SSR. Both the same.

Being a Mach newbie any help would be greatly appreciated!

I email Arturo with my wiring diagram and he said it should work.

TIA,

Steve

Offline Tweakie.CNC

*
  • *
  •  8,804 8,804
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Another help request.
« Reply #1 on: August 14, 2012, 07:58:04 AM »
Hi Steve,

That's a strange one - I use numerous SSR's on my machine without any problem.

I presume you measured the voltage at 5.22V with the SSR connected ?? if that is the case then check that your GND return, from the SSR, is connected to the correct point.

Tweakie.
KEEP SAFE !
Re: Another help request.
« Reply #2 on: August 14, 2012, 08:56:56 AM »
What are you trying to switch?  SSR's won't work with everything AC.  They usually won't work with motors that have electronic start circuitry or any kind of electronic speed contol.  Older motors that have centrifugal/mechanical start mechanisms work fine.  If the motor doesn't make a clicking sound as it slows down, it has electronic start circuitry.  We've also had trouble switching some solenoids using SSR's.
« Last Edit: August 14, 2012, 08:59:15 AM by rrc1962 »
Re: Another help request.
« Reply #3 on: August 14, 2012, 09:22:07 AM »
Tweakie, yes the voltage was measured at the SSR and the grounds were good.

RRC, I am turning on a Porter Cable router. The circuit (SSR) and AC cable wiring worked as planned with the 6VDC battery on the input side of the SSR.

I removed the 5VDC power supply and tried it direct to the SSR and no go.. was on to something. Got another 5VDC power supply and connected it directly to the SSR and it worked so I connected the new (working) power supply as the C10 +5VDC source and reconnected everything else and it is NOT working.

I am rethinking this thing. Looks like maybe a current limit out of the C10. The new power supply has plenty of power and is 2A rated so that should not be the issue.

I may get a smaller DC Relay to switch the voltage on/off to the SSR and see if that works.. switch to turn on a switch...

Any ideas appreciated.
Re: Another help request.
« Reply #4 on: August 14, 2012, 10:31:59 AM »
FIXED!!! When in doubt, check that which is assumed.

Assumption: When passing color coded wires thru a cable connector, the color that goes in is the same color that comes out, especially when only red and black are used!

What happened. All my testing was good and worked except when I re-connected all of the wires that went thru the connectors. All of these were good except one pair. The Red and Black pair going to the SSR. So, the polarity was inverted so the switch did not work!

All day for a stinking factory color code problem.

Now to check the E-Stop!

Thanks guys. You helped me think thru it.. A good night sleep helped to!

Steve