Hello Guest it is September 21, 2019, 11:01:05 PM

Author Topic: re:CNC Lathe program  (Read 30240 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: re:CNC Lathe program
« Reply #100 on: August 11, 2012, 05:44:00 PM »
You have Incremental IJ  mode chosen and also you are running in Radius mode.
If you wish to run Radius then you will need to use the radius Post Processor.
The IJ mode needs to be set to Absolute, as mentioned earlier the best way to do that is in your code by having a G90.1 at the start. Changing it in General Config will also do it but the danger there is some other code may change it to Absolute and then if your new code is written in Absolute mode and there is no G90.1 at the start it will not produce the correct toolpath.
Hood
Re: re:CNC Lathe program
« Reply #101 on: August 12, 2012, 01:03:11 PM »
Hood
In one of my earlier post i stated that I had made the changes to Mach going to Dia & absolute also the code had a G90 at the start but the screen showed the same crop circles and the cutter followed the display so for sure something is wrong just don't know what?

Thanks
Dennis 

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: re:CNC Lathe program
« Reply #102 on: August 12, 2012, 01:40:39 PM »
The xml you attached does not have these changes and when I changed them it displayed correctly so try again as it seems you did not change them correctly.
Oh and BTW it is not G90 it is G90.1.
G90 & G91 are distance mode, G90.1 & G91.1 are IJ Mode

Hood
Re: re:CNC Lathe program
« Reply #103 on: August 12, 2012, 02:10:46 PM »
Hood
I work with the settings in Mach and got it to display the proper code file Balls for Dennis What i changed was Diam unchecked reverse Arch, Distance changed to absolute and IJ to absolute and the code displayed was correct so i think i have the problem fixed at least it seams so right now next i will go back to Dolphin and see if i can draw a part and code it to run on Mach.

Many thanks for your and Rich help
Dennis

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: re:CNC Lathe program
« Reply #104 on: August 12, 2012, 02:27:27 PM »
Dia unchecked is not correct for that file as Rich used the Dia post processor, you need Dia chosen for that. If you wish to use Radius you will need to use a Radius post processor for Dolphin.
If you have Dia unchecked and it is showing correctly then I dont know how unless you did not regenerate the toolpath.

Hood
Re: re:CNC Lathe program
« Reply #105 on: August 13, 2012, 01:06:35 PM »
Hood
 I checked it and then tried the code the cutter would clip the back side of the balls but when i unchecked it the cutter ran along the back side with out clipping them.

Dennis

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: re:CNC Lathe program
« Reply #106 on: August 13, 2012, 01:22:09 PM »
Dennis, please attach the xml you have changed as I am perplexed as to  how it could possibly be showing correctly if you are in Radius mode when the code was written in Dia mode.
Hood

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: re:CNC Lathe program
« Reply #107 on: August 13, 2012, 09:00:44 PM »
Dennis,
The xml I posted in reply #96 works and brings up the standard lathe screen set. So if you do nothing other than just load the program posted in reply #73 it will run and the path shown is correct.

You absolutely need to have your xml correct so you know what is being portrayed is correct, and if not, you probably did a booboo in Dolphin.
I will echo again, IE; Draw in diameter, configure Dolphin for diameter, use a Dolphin diameter post, have Mach configured for diameter. Do not mix diameter with radius anywhere along the way. KISS applies  ;)

I am still waiting for my license. I requested a pp for radius and diameter but as provided they did not work for V11.  :(
Not sure what they sent you Dennis...read on.

Hood,
Thanks for the pp mod as it worked for both of the V10 pp's for use in V11. I looked in the manual and there is not crap on what to do.
Now I want to just confrrm that they  post correct pathing to have confidence in them ( so far so good   :D).  Also got the CAD import to cam profile
creation down path, hey hey , amazing what one wrong click can do......  ::)

RICH

Re: re:CNC Lathe program
« Reply #108 on: August 14, 2012, 05:19:56 PM »
Rich
Dolphin kept sending me a different post every time i contacted them it was hi Dennis try this post see if it works so i don't know what they sent but i am with you on the kiss method i will use the #73 and #96 see what happens thanks again.

Dennis

Offline RICH

*
  • *
  •  7,361 7,361
    • View Profile
Re: re:CNC Lathe program
« Reply #109 on: August 14, 2012, 11:05:38 PM »
Dennis,
I'll get Mach3 diameter & radius post processors posted on this site for your use with V11.
1. You need to have Mach display properly using what was posted.
2.Then when 1. is working, you will need to learn a few things in Dolphin CAD so you can create a proifle for use in the CAM.
   Dosen't work like V10 did.
   I will post a how to do that including adding the pp's to the program.
3.With the CAD working and the pp's installed, then you will need to learn how to use the CAM part. Let not your heart be troubled
   as i will post another example how to.

Dolphin is working on updating the site to have new pp's for V11 available for downloading and new documentation. Should you get bored,
search you tube as there are number of videos which one should watch very carefully.  ;D

Remember that this is all fun,   ;)
RICH