Hello Guest it is May 23, 2019, 01:44:59 PM

Author Topic: Please Help, Did a Windows Vista update, Now Mach3 pauses between lines of code  (Read 2256 times)

0 Members and 1 Guest are viewing this topic.

Offline btu44

*
  •  28 28
    • View Profile
Hello,

Please look at this short video of my system after I did the latest Windows Vista Update

http://www.youtube.com/watch?v=c7wAvIYpWw0&feature=youtu.be

The biggest problem are the pauses between line of code in the X or Y axis. It does not seem to have a problem with the Z axis.

Things that I have tried to fix it:

1) Searched Mach3 forum...I saw a few posts but see no resolutions.
2) Installed R3.043.062...Pauses stayed the same but had other issues. Went back to R3.043.022
3) Used Windows System Restore to a point when Mach3 was working fine...Still have pauses.

Any ideas would be greatly appreciated. I have a job for the mill coming up and I don't think I can run it this way.

Other issues that are just minor but maybe someone has an answer.

1) Long spindle Dwell after spindle start up but before Z axis movement. Shown towards end of video.

2) While in Single Step mode and Feed Hold is pressed while the machine is still in motion. Pessing Cycle Start, Single Step mode is disabled.

Thanks for looking,
Barry

Offline btu44

*
  •  28 28
    • View Profile
I made a new video that illustrates the problem much better.

http://www.youtube.com/watch?v=0mptQKTIAGc&feature=youtu.be

I've spent 2 days on this so far and am running out of ideas.

Could this be a new hardware issue and not Mach3 ???

Barry
Barry,
Check to see if you are running Mach3 in Exact Stop mode.

Regards,
John Champlain
www.picengrave.com

Offline btu44

*
  •  28 28
    • View Profile
OK, this weird. I found the suggestion earlier to check the CV / Exact stop setting in General Config.
I tried both settings to no avail. (My code header always set it back to CV)
Since I appreciate your reply I gave it another try and dam it, work fine now.

This is really starting to sound like a computer hardware problem. The temperature dropped about 15F since I tested last.

Anyway thanks for the help and the other the took a look.

Now if anyone else has an idea about the long dwell and the single step issue...I'm all ears.

"Now if anyone else has an idea about the long dwell and the single step issue...I'm all ears."

Do you have a delay set in: Config > Ports and Pins > Spindle Setup > General Parameters  ?

John Champlain
www.picengrave.com

Offline btu44

*
  •  28 28
    • View Profile
Yes, I've made sure that all the spindle delays are at 0.
I have even used an XML reader to find a dwell setting. I didn't see anything obvious.

Barry