Hello Guest it is March 09, 2021, 05:29:23 AM

Author Topic: A axis preview won't rotate in realtime ????  (Read 3113 times)

0 Members and 1 Guest are viewing this topic.

Offline Tarak

*
  •  227 227
    • View Profile
A axis preview won't rotate in realtime ????
« on: January 14, 2007, 07:23:56 AM »
I've noticed that A axis will not rotate in the preview window like it used to, it did rotate in realtime.
Now it only rotates at the end of a move.
So if I have....
G1 X100 A90
you can see X axis move along but A axis is stationary (DRO is moving though) until it finishes the move and then the preview jumps to A90
BTW this isn't on a machine yet I'm just making a screen.
I also tried the standard screen and it still did it, Is it a setting I've inadvertantly changed?

Offline rcrabb

*
  •  146 146
    • View Profile
Re: A axis preview won't rotate in realtime ????
« Reply #1 on: January 14, 2007, 10:35:07 AM »
In the Config> Tool path settings check that you have the correct things selected. I posted a pic of my setting that work. Also put it in jog follow mode. Good luck
Ryan

Offline Tarak

*
  •  227 227
    • View Profile
Re: A axis preview won't rotate in realtime ????
« Reply #2 on: January 14, 2007, 05:49:16 PM »
Thanks rcrabb, your right if I enable jog follow it works, any idea how to use it without jog follow?

Offline rcrabb

*
  •  146 146
    • View Profile
Re: A axis preview won't rotate in realtime ????
« Reply #3 on: January 14, 2007, 06:02:49 PM »
nope.
Ryan
Re: A axis preview won't rotate in realtime ????
« Reply #4 on: January 14, 2007, 09:22:16 PM »
That was a small bug and we knew about it :) Should be fixed in the next rev...
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline Tarak

*
  •  227 227
    • View Profile
Re: A axis preview won't rotate in realtime ????
« Reply #5 on: January 15, 2007, 12:36:57 AM »
Fantastic, thanks guys.