Hello Guest it is June 19, 2019, 11:48:22 AM

Author Topic: Trouble at first test  (Read 1865 times)

0 Members and 1 Guest are viewing this topic.

Trouble at first test
« on: June 14, 2012, 11:47:40 PM »
Just put my new DIY CNC together and tried to test it tonight. I am running an HP NC6320 running 32-bit Windows XP Pro. I know there are several issues with running laptops but it seemed to be working ok during a 'dry' run of Mach 3. I wired everything up but only wired the Y-axis motor to test. I tried running the roadrunner.tap (no router installed) just to see if it moved. Everything on screen looked like it was fine but I had no movement. So I tried just jogging it but still nothing. It was getting late so I did no further troubleshooting. Any ideas? The drivestest on the laptop showed about 23.877 Mhz and was pretty steady.

What are the likely scenarios? laptop? not having all motors connected? mis-configured software?

Now that I think of it I only enabled one motor in the pins and ports settings. I might have enabled the wrong one. I won't get to look at it again until late Saturday or some time Sunday.

Any thoughts in the meantime?

Offline RICH

*
  • *
  •  7,338 7,338
    • View Profile
Re: Trouble at first test
« Reply #1 on: June 15, 2012, 05:26:47 AM »
Could be caused by a number of things.
Is the reset button blinking? IF so click it.

Post your xml file and someone can take a look and see if there is anything wrong.

RICH
Re: Trouble at first test
« Reply #2 on: June 15, 2012, 07:50:16 AM »
The reset button wasn't blinking. I'm going to look over the documentation but I won't get a chance to look at the laptop or the CNC until later tomorrow so I can't get you the XML file yet. I'll let you know what I find though. I was in a bit of a hurry to see the thing move so I probably missed something in the setup.
Re: Trouble at first test
« Reply #3 on: June 17, 2012, 11:32:10 PM »
Got everything working. The problem was that I forgot to import my xml file. I did that and connected all 3 motors and all run. The only things I need to do now is configure my soft limits. I don't have limit switches on it yet. It runs to, and try to go past, the gantry upright. I also need to install my table bed and router. I need to tidy up my wiring too. When I ran the circle bolt pattern (included in the Mach 3 wizard) it runs fine. But when I tried to run the rectangular box using the default measurements, it runs out of Y travel.

The other thing that I noticed is the when the Z is moving down, such as going to a deeper cut, it makes a different type of 'grinding' noise. It will go up and down and I get the normal 'hum' but when it looks like it is making a 'hole' it slows a little and makes what seems like a grinding noise.

Hopefully I get to make something by this weekend.

BTW-I am running Mach 3 on an HP NC6320 laptop. I am running XP Pro and haven't made any special changes or settings.