Hello Guest it is July 07, 2020, 12:11:01 AM

Author Topic: Need help can i flip the code design  (Read 2637 times)

0 Members and 1 Guest are viewing this topic.

Need help can i flip the code design
« on: June 10, 2012, 05:55:06 PM »
Hi

I am designing things in V Carve and it it a pain in the butt to design something and then have to flip it all to cut on my CNC th see id side ways and have to re-line everything.

It is designed sideways but it can to cut in my cnc that way.

Can i do this in Mach 3 after i load in the code for the design some how?

My cnc cuts 20 wide by 30 long and my designs are 24 long by 7 to 10 tall so they need to be fliped to be able to cut down the 30 inch side of the cnc.

Can i load in the design code and just click on something in Mach3 to rotate the design before cutting it.

Thanks
Re: Need help can i flip the code design
« Reply #1 on: June 10, 2012, 06:12:09 PM »
Hi,

A quick solution may be to swap the plug for the X and y axis motors on the controller, assuming that the leadscrews are the same.

Alternatively, go into Maxh3 and swap the pin assignments for the two axis.  Make the long axis X and the short axis Y

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Need help can i flip the code design
« Reply #2 on: June 10, 2012, 07:09:47 PM »
How do i
go into Maxh3 and swap the pin assignments for the two axis.  Make the long axis X and the short axis Y

I am not sure what to do and in what place ???

Thanks

Offline Tweakie.CNC

*
  • *
  •  8,347 8,347
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Need help can i flip the code design
« Reply #3 on: June 11, 2012, 02:56:01 AM »
Quote
Can i load in the design code and just click on something in Mach3 to rotate the design before cutting it.

Hi Eddie,

On the Mach3 'MDI' page see 'Local System Rotated'

Tweakie.
KEEP SAFE !
Re: Need help can i flip the code design
« Reply #4 on: June 24, 2012, 07:22:59 PM »
Ok i think i got it - i set it to 90 and then did a test run not cutting but it looked like that will work as it ran the long way.

Thanks