Hello Guest it is August 11, 2020, 12:57:02 AM

Author Topic: ESS works on one PC but not another  (Read 13646 times)

0 Members and 1 Guest are viewing this topic.

ESS works on one PC but not another
« on: June 04, 2012, 04:07:26 PM »
 I got the ESS working on one pc but the computer that I want it to run on doesn't commincate with the ESS.
I have used the Bootp jumper and used the configurator set to 10.9.9.9
The PC indicates that the netowk cables is connected
The configuarator shows the file being updated.
When I click on connect, program and disconnect it show the file being updated and then I get the brief message that the cable is disconnected.
On the LED array I get a single green led flashing slowl\y on and off.

I then disconnect the jumper  and shut off the ESS and load mach3.
After mack 3 is loaded and I select the ESS plugin ver 2 I get a messge message the the wakeup client board does not reply
When I click on No I get the IP configure menu and I enter 10.9.9.9
The I get a screen that say I have more than one control device but the listing of the control devices is blank

Last I then go to the plugin control and click on configure and try to enter 10.9.9.9 there but that doesn't do anything,.
Suggestions?
Dan

Das
Sugges

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: ESS works on one PC but not another
« Reply #1 on: June 04, 2012, 05:52:27 PM »
Tried disabling the windows firewall?
Hood
Re: ESS works on one PC but not another
« Reply #2 on: June 04, 2012, 07:33:19 PM »
Yes the firwall is shut down.
Re: ESS works on one PC but not another
« Reply #3 on: June 05, 2012, 12:01:41 PM »
Here is a screen shot of the problem
dan

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: ESS works on one PC but not another
« Reply #4 on: June 05, 2012, 01:05:26 PM »
You may have more luck emailing Greg direct.
Hood

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: ESS works on one PC but not another
« Reply #5 on: June 06, 2012, 10:13:08 AM »
The most likely cause is your firewall is blocking the communication. You have to allow both the configurator and mach through the firewall. Also, if you have a newer PC with a Gigabit Ethernet port it will be able to 'auto crossover', i.e. it can talk with an Ethernet device directly over a regular Ethernet cable. Older Ethernet ports cant do that and will require a cross over cable.

Also, the first time you fire up Mach with the ESS you will get the message that it can't find the ESS, you have to go into the ESS configuration and set the IP address, if it connects it will save the IP address in your profile. If it does not connect it will never save the IP address you just entered.
Happy machining , Jeff Birt
 
Re: ESS works on one PC but not another
« Reply #6 on: June 06, 2012, 11:19:01 AM »
 Thanks for the help Brit but I do have the firewall shut off. I have tried both a crossover cable and a standard ethernet cable.
I then tried a third pc.
I tried both the configirator and the mach3 plugin config on it . The problem is that while the LEDS show a connection. I cannot get it to communicate. I see that in the control panel I get the limited or no connection error message. When I do an cmd> ipconfig it shows the IP address as 0.0.0.0
When I try to renew the IP address that doesn't work either. I switched cables to no avail.
Dan

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: ESS works on one PC but not another
« Reply #7 on: June 06, 2012, 11:36:00 AM »
Did you configure your IP setting for the Ethernet port on the PC? You have to set the PC to default to the same subnet as the ESS. Since you are seeing a 0.0.0.0 from ipconfig it sounds like that might be the cause.
Happy machining , Jeff Birt
 
Re: ESS works on one PC but not another
« Reply #8 on: June 07, 2012, 04:07:33 PM »
Here is some instructions that in my opinion are easier to follow in setting up the ESS
and  are less confusing
1. D/l and install the ESS Plugin  for mach3
2. Copy the Configuator program to the mach3 directory.
3. At the Desktop click on Start>Control Panel>Network Connections> right click on Local Area Connections>click on Properties> cursor down and select Internet Protocol>click on Properties>click on "Use the following IP address" then enter 10.9.9.1 and the Subnet Mask should be 255.255.255.0> click on OK>click on OK and close the control panel
4. Place the jumper over both pins of the BootP header which is next to the connector for regulated 5VDC
5. The bottom of the ESS board has the polarity for connection of a regulated 5V marked . Make sure you connect the power supply (wall wart or or other PS  as long as it is regulated and 5VDC and connected to the correct terminal on the ESS.  Connect the power supply to the AC source
6 Connect a standard Ethernet cable with rj45 connectors to the PC connector and the ESS board.
7 In the mach3 directory open the Configurator program.  The IP address should be 10.9.9.9 . Click on " Connect, Program and disconnect" button. In a few seconds to a minute you should see a file being updated.
8. Click on EXIT and shutdown power to the ESS and remove the jumper from the BOOTP header. Reconnect the power to the ESS.
9. At the desktop click on the Mach3mill /mach3Turn icon. After loading Mach3 select function cfg'S . Select Reset Device selection. Close mach3 and restart.  Click on Agree to terms>Select the ESS_V10b2  control device If a message that the "Wakeup client Board does not respond" click on NO. Enter 10.9.9.9. into the SmoothStepper Board IP address. Click on OK. The ESS should now be updated and then you can click on Plugin Control and set your parameters.
10 At this point you should have 3 flashing green LEDS AND 1 SOLID GREEN LED Llights on the ESS board. You are now set to go.

Dan  Mauch



Re: ESS works on one PC but not another
« Reply #9 on: December 06, 2012, 04:39:39 PM »
Thanks I am at Hardware stage right now, but the clarity of your instructions seem very helpful.