Hello Guest it is September 17, 2019, 05:42:06 PM

Author Topic: Herky-Jerky Z  (Read 1760 times)

0 Members and 1 Guest are viewing this topic.

Herky-Jerky Z
« on: June 01, 2012, 04:50:49 PM »
After cutting 100 of the same piece without trouble, or change to any setting, the Z started plunging deeper on the piece. It would plunge to drill a hole and not lift up the specified amount. As it continued to drill the next couple of holes it wouldn’t pull up enough to clear the surface and would route a line leading to the next hole. I’ve tried turning everything off and restarting everything and I get the same issue.  I noticed when I was cutting the previous pieces that when the machine returned to the start position after completing the job the DROs for X & Y were not zeros so I would just hit “Go to Zero” and then start the next job.
  When it started ruining material I decided to check the steps on the Z axis and when I did, I found that the positive direction was fine but when I went in the negative direction it was off a bit. I tried going back and forth with calibrating the steps and could get close but not as close as I would like so I went in to motor tuning and stepped up the acceleration and velocity wondering if that might have some effect on the stepping. Much to my dismay the motor for the Z started to vibrate badly so I ran it to the limit switch and it stopped. After resetting the acceleration and velocity back where I had it (60 and 10 respectively) I got the jogging to slow down but it still vibrates badly even when no jogging is taking place. When you look at the motor it is just going back and forth rapidly causing the spindle to shake up and down until I either close the program or run it up to its limit switch.
  Is there anything you can tell me that might help?

Thanks a bunch - bingart
Re: Herky-Jerky Z
« Reply #1 on: June 01, 2012, 05:01:45 PM »
What kind of "motor drives" are you using ?
Re: Herky-Jerky Z
« Reply #2 on: June 01, 2012, 05:06:43 PM »
They are belt driven servos. If that is what you mean, I'm rather new to this whole thing of CNC.

Thanks - bingart
Re: Herky-Jerky Z
« Reply #3 on: June 01, 2012, 07:55:45 PM »
i have dealt with those issues before, they were caused by :

1.) my Gecko drives needed to be tuned, which is why I was wondering what kind of motor drives you had.
2.) when I assembled my machine I grounded the motor drive encoder grounds to the cabinet chassis - it caused noise to affect the step and direction signals and stopped after I disconnected the ground.
3.) the acceleration settings in Mach3 were too agressive.

spend some time to find out how your motors are being driven, follow the wires from the encoders on the motors to where they terminate and find out
what that particular unit is and who makes it. Then investigate to see if it can be adjusted I believe the adjustments are refered to as P.I.D. - Integral, Differential and something else I cant remember at the moment. These adjustments had a really profound effect on motor performance.
Re: Herky-Jerky Z
« Reply #4 on: June 02, 2012, 08:48:42 PM »
Thanks Ivan,
  I got her back up and making chips. I actually do not understand this whole thing. I turned everything off yesterday after my failed attempts and left it for me and it to cool off. I fired it back up this afternoon and it working just fine again #@?*&!!! javascript:void(0);