Hello Guest it is January 29, 2020, 10:47:26 AM

Author Topic: mach3 mill Problem with G2/G3 and G18  (Read 4710 times)

0 Members and 1 Guest are viewing this topic.

Offline kvom

*
  •  37 37
    • View Profile
mach3 mill Problem with G2/G3 and G18
« on: May 23, 2012, 04:58:52 PM »
Using the mill as a lathe with stock held in mill collet and tool in lathe.

G2 and G3 seem to be reversed.  If I replace G2 with G3 and vise-versa, my part is made correctly.  The toolpath display shows it incorrectly either way.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #1 on: May 23, 2012, 05:15:12 PM »
Are you loading a Turn Profile?
Hood

Offline kvom

*
  •  37 37
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #2 on: May 23, 2012, 05:41:44 PM »
Using standard mill profile.  I did try to use the turn profile that came with the install but I get no fields.  Using the TurnAddon screens I get the same toolpath display.

Same result with both the lockdown and later versions.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #3 on: May 24, 2012, 03:27:48 AM »
Not really sure what you are meaning by "I get no fields"
Also not sure what you are meaning by "using the TurnAddon screen"

What I would suggest is you clone the profile for your mill and then open it and load a turn screen (1024.lset) and then restart that profile and see what things look like.
Hood

Offline RICH

*
  • *
  •  7,403 7,403
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #4 on: May 24, 2012, 06:46:47 AM »
Maybe consider using MSM as that provides for using your mill along with a rotary table as a lathe.
RICH

Offline kvom

*
  •  37 37
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #5 on: May 24, 2012, 08:48:25 AM »
Not really sure what you are meaning by "I get no fields"
Also not sure what you are meaning by "using the TurnAddon screen"

What I would suggest is you clone the profile for your mill and then open it and load a turn screen (1024.lset) and then restart that profile and see what things look like.
Hood

That seemed to resolve the display issue.  I was not aware of the difference between lset and set.

Here's the small part I was making:



I'll try it this afternoon to see if the actual paths are OK.
« Last Edit: May 24, 2012, 08:58:48 AM by kvom »

Offline kvom

*
  •  37 37
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #6 on: May 24, 2012, 12:01:15 PM »
Checked it on the mill today and got correct paths.  But it seems there must be an issue with G2/G3 and G18 in mill mode.  Not worried about it now though.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 mill Problem with G2/G3 and G18
« Reply #7 on: May 24, 2012, 01:55:32 PM »
Not thought too much about it but would the G2/G3 thing not be the difference between tool doing the moving and workpiece doing the moving?
Anyway whatever it is if using the mill as a lathe with the work in the spindle the easy option is to use a turn profile where arcs are reversed in front toolpost.
Hood