Hello Guest it is September 15, 2019, 04:53:58 PM

Author Topic: Indicator led lights  (Read 3750 times)

0 Members and 1 Guest are viewing this topic.

Indicator led lights
« on: May 21, 2012, 06:52:49 PM »
I am having problems with my flame cutter.   I have narrowed the problem down to either the parallel port or wrong ports and pin settings.   Is there a way I can add a light on my screen that changes color when the switch is made that detects the top of the plate on my z axis?

I am using the BOB from Tom at candcnc.   



Thanks



Steve

Offline Tweakie.CNC

*
  • *
  •  7,903 7,903
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Indicator led lights
« Reply #1 on: May 22, 2012, 02:33:37 AM »
Hi Steve,

Use one of the Mach3 Screen designers to add an LED in an appropriate place on your screen. This LED is then mapped to your switch.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Indicator led lights
« Reply #2 on: May 22, 2012, 03:29:35 AM »
You're asking the wrong question. There's already a digitize LED. If you'd come back with your XML as I requested in your previous thread we could have continued trying to find the problem.
Indicator led lights
« Reply #3 on: May 22, 2012, 07:32:47 PM »
Stirling-  I am having problems trying to upload my file.   I changed hosting companies.   I should get it fixed tonight.   

I did work on my computer on the flame cutter.   I installed the latest version of mach, and the random crashes have stopped for now anyway.

I still have to uninstall and reinstall the second parallel port before the LEDs change on the diagnostic page that Tom has.


Steve
Re: Indicator led lights
« Reply #4 on: May 22, 2012, 10:51:47 PM »
bad news-

Went to the shop, powered everything down, and back up.  The computer is back to randomly locking up with Mach :(


this is a Dell Optaplex 530 I think.  I read someplace that dell optaplex and Mach don't play well together.


Steve

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Indicator led lights
« Reply #5 on: May 23, 2012, 02:54:48 AM »
Do you have a high kernel? If you do then that may be the cause of the lockups. What is the time in Int shown on the Diagnostics page?
Hood
Re: Indicator led lights
« Reply #6 on: May 23, 2012, 11:07:15 AM »
Hood-

The computer is a intel pentium 3.00 with 2.0 gig of ram.  the time in int is +7.1, but this number jumps between 6.5 to 7.5 ish.    The kernel speed is set at 60,000.


Thanks


Steve

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Indicator led lights
« Reply #7 on: May 23, 2012, 02:21:10 PM »
Do you need the 60KHz kernel?
Your Time in Int although not excessively high means the driver is taking 7uS of every 16uS to do its thing and only leaving 9uS for everything else that is going on on your computer (Machs other functions, Windows etc)
Dropping to 45KHz if possible would leave 15uS.

Hood
Re: Indicator led lights
« Reply #8 on: May 23, 2012, 09:14:54 PM »
Hood-

I changed it to 45KHz and the Time to Int is still right around 7 uS.   I don't think I can go much lower, because I am using 30 to 1 gearboxes.   I have most everything disabled on this computer-- no virus scan and stuff like that


Steve

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Indicator led lights
« Reply #9 on: May 24, 2012, 03:24:39 AM »
Time in int will not change as that is dependant on the particular computer, changing the Kernel however changes the interrupt time for example
25KHz = 1 second/25,000=40uS
45KHz = 1 second/45,000=22uS
100KHz = 1 second/100,000=10uS

So as you can see the higher the kernel the more time, as a % of the interrupt, the driver will be taking up and thus the less time for the rest of the computers functions which includes Machs normal running and everything else windows is doing. That is why on some computers you are more prone to have lockups the higher the kernel you have. On my computer here at home the Time in Int is 2.5 so even at 100KHz my computer is only 25% a pulsing engine and 75% is left for other computer tasks.


Did changing to 45KHz help any?
Hood