Hello Guest it is January 29, 2020, 02:37:34 AM

Author Topic: A axis problem with Sherline and Gecko 540  (Read 2411 times)

0 Members and 1 Guest are viewing this topic.

A axis problem with Sherline and Gecko 540
« on: May 20, 2012, 03:39:02 PM »
Just now moving into some A axis milling using my cnc rotary table.  Part is rotating about the X with no movement of the table in the Y.  Using CNC Wrapper to convert Y axis to A Axis angular commands.

I've got the motor tuned so it works fine.  400 steps for the A axis rather than the 40,000 on the other axis gives me the correct movement.  Also set the speed and velocity for acceptable amounts and it works just fine using the jog keys.

The problem I have is when sending commands such as G1 A10 (gives me 10 degrees of movement) it gets there but literally takes 8 seconds to go just one degree.  Again, jog speeds are fine and I can change then so that jog is way faster than anyone could desire so I'm assuming I've missed a setting somewhere.

I should probably also mention that the Mach3 screen doesn't say A axis....it the X, Y, Z, and 4 axis (reading from top to bottom).  I also noticed when I watch the 4th axis DRO it is 'moving' at a nice pace just like the X, Y, and Z do.  However, there is a big difference between going 1 inch and 1 degree.  I suspect that has something to do with it as it appears the A axis is trying to move at the same 'linear' pace as the other axis.

Suggestions?

Thanks,

Mark
« Last Edit: May 20, 2012, 03:48:54 PM by 72Zorad »

Offline Greolt

*
  •  956 956
    • View Profile
Re: A axis problem with Sherline and Gecko 540
« Reply #1 on: May 20, 2012, 04:10:10 PM »
You need to use the "Rotary axis feedrate compensation" feature.

The following is a copy of a post I made some time ago about this feature.

===================================================================

All axis move in units per min.   With a rotary axis those units are degrees.

So what is 60 ipm on the linear axis (desired speed of the tool in the work), is 60 degrees per min for the rotary.

That 60 degrees per min angular feedrate will make the tool move through the work at a speed dependant on the distance the tool is away from the centre of rotation. (in your case, very slowly)

So Mach has a feature to compensate the rotary axis feedrate, to accommodate differing radius that the tool is cutting at.

It is activated via the Toolpath Setup menu.   Check "Use Radius for Feedrate"  All the other settings in this box are to do with the toolpath display window.

On the Settings page there are three DROs labelled "Rotation Radius".  IMO they would be better labelled "Rotation Radius Offset"

They are to tell Mach the distance that the relevant axis origin (Z in this case) is offset from the centre of rotation.  (A axis in this case)

So if you are machining on the outer surface of a 10 unit diameter job and Z axis origin (zero) is set on that outer surface, then the correct value for the "Rotation Radius Offset" DRO is 5.  The distance that Z origin is OFFSET from centre of rotation.

If, on the other hand, the Z axis origin is at the centre of rotation (my preferred method for most jobs) then the correct value for "Rotation Radius Offset" DRO is zero.  The distance that Z origin is OFFSET from centre of rotation is zero.

Mach takes the Z axis DRO value and the "Rotation Offset Radius" DRO value and adds them together to ascertain at what radius the tool is cutting at any one time.  Then compensates the angular feedrate to have the tool move through the material at the desired speed.

Maximum velocity as set in motor tuning is honoured, so that will always be the upper feedrate limit.

Now there is one little "Gotcha".   A zero value in the "Rotation Radius Offset" DRO will automatically disable the entire feedrate compensation feature.  This is a known bug and is being addressed by Artsoft at this time.  Hopefully it will be fixed soon.

The workaround for this, is to use a very small value (eg. 0.001) in the "Rotation Radius Offset" DRO when zero is the correct and desired value.  Small enough to have no measurable effect on feedrate, but not zero.

=================================================================================================

Note that the issue referred to in the last two lines has been addressed but I forget which version this was done.

Hope this helps,

Greolt
Re: A axis problem with Sherline and Gecko 540
« Reply #2 on: May 20, 2012, 04:19:45 PM »
That's funny...I was just coming back to the post to provide this link which says much the same thing although your explanation says why :)

http://www.machsupport.com/forum/index.php?topic=1117.0;wap2

I had searched for an answer for some time then posted the question....continued my search while waiting and eventually found the answer.  Thanks for the detailed explanation.

Mark