Hello Guest it is March 01, 2021, 06:00:25 PM

Author Topic: M6T" tool change sequence does not load tool # in DRO  (Read 3832 times)

0 Members and 1 Guest are viewing this topic.

M6T" tool change sequence does not load tool # in DRO
« on: May 14, 2012, 11:32:54 AM »
good day all

would anyone one know why an M6 command will not change the number in the TOOL# DRO to anything but a 0
I suspect it is in the macro but i'm not sure what should be changed.
i don't have a tool changer on my lathe but my tool post will hold up to 4 tools and with an M6 command, the saddle, rapids to a tool change position, set in the diagnostics screen and the TOOL # DRO sets itself at 0 - if i forget entering the tool number in the DRO before hitting the cycle start... the machine rapids to the limit switches  :o NOT GOOD!
I have "stop spindle and wait for cycle start" turned on in the Mach3 general config window

I've attached the macro if anyone has time to look and see where my problem might be

thanks all

Mac

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #1 on: May 14, 2012, 01:43:26 PM »
How are you calling the tool?
Hood
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #2 on: May 14, 2012, 02:10:16 PM »
good day Hood

for tool #1 - M6 T1 _ should it be M6 T01

thanks
Mac

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #3 on: May 14, 2012, 03:17:20 PM »
On a lathe you call the tool with TAABB where AA is the tool number and BB is the offset number, eg T0101

Hood
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #4 on: May 14, 2012, 03:50:58 PM »
well there ya go... another wrinkle in the brain

i'm not formally trained in CNC g-code - just what i've picked up along the way

with the old controller on this machine it never showed me that... the conversation was a different language than Mach

i'll give that a try and let you know

thanks Hood

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #5 on: May 14, 2012, 04:00:39 PM »
Ha ha I can remember when I was first retrofitting my lathe. I did the ladder in the PLC here at home and as I was used to Mill (and wasnt keen on the Turn screen). I was using it to test out the sequence in the ladder (switches connected to PLC for simulation). It worked perfectly. I then made a new screenset up for turn but I couldnt get the ladder to work in the PLC and it took me a wee while to work out why, I had been calling M6T* instead of T****, so you are not the only one  :)
Hood
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #6 on: May 15, 2012, 08:10:47 AM »
Hood

that got it!! Thanks a pile

just finished tweaking my post and looks like it'll work

have yourself a great day!!!  ;D

Mac

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: M6T" tool change sequence does not load tool # in DRO
« Reply #7 on: May 15, 2012, 09:17:44 AM »
No probs :)

Hood