Hello Guest it is February 27, 2021, 01:42:48 AM

Author Topic: Noob Has questions  (Read 1571 times)

0 Members and 1 Guest are viewing this topic.

Noob Has questions
« on: May 11, 2012, 10:36:53 AM »
Here's what I have

A shirline 5400 mill (inches) its about 10 years old. I added a kit from keling to cnc it and have set it up so there are 32000 turns per inch
200 steps X 8( for 1/8 step) X 20(.05 inches per turn) = 32000
its seems to work correctly.

I have used Rhinocam to generate the Gcode and used mach3 sherline as the post processor.

When I ran the code the y axis cut fine but the x axis shrunk by about half. I looked at the settings and all three axis are set the same, I checked the drivers and they are set the same as well. Any ideas?

Next question, When I am setting up the mill and zeroing out the piece how do I determine the edge of the stock? Is it spindle over the stock until it reaches the end or is it moved to the stock and set when the spindle comes in contact with the edge?

Thanks in advance

Andy

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Noob Has questions
« Reply #1 on: May 11, 2012, 01:15:28 PM »
Does the toolpath view in Mach look correct?
If you command a move from MDI does the X move that distance?

It will all depend on your programme but if the lower left corner of the stock is X0, Y0 then what I do is jog close to the part then step away until I can get a feeler gauge in. Say the tool is 8mm and the feeler 1mm I would then tell Mach the position is -5 (cutter radius plus feeler) and enter that direct into the DRO, then repeat for the other axis. The Z can be set the same except you only need to enter the feeler gauge thickness  and it will be a positive value.
Hood