Hello Guest it is February 27, 2021, 11:53:42 AM

Author Topic: Mach recognizes limit switches then ignores them  (Read 3261 times)

0 Members and 1 Guest are viewing this topic.

Offline kosmo

*
  •  10 10
    • View Profile
Mach recognizes limit switches then ignores them
« on: May 02, 2012, 05:18:01 PM »
Hello
I have a Bridgeport Boss 4 retrofitted with C32 bob, using existing limit switches wired NC with 5 volt power. I have xyz +-home enabled and active low, port and pins 2-12 2-13 2-15 are used.
When I first turned on mach it said that inputs needed corrected and that mach would toggle and make the change. During this time the diagnostic screen showed the limits activated. I could engage the machine limit and the respective limit light would respond. I let mach make the changes in order to RESET and from that point on it no longer would recognize the switch activation.
Anyone with similar problems or ideas ? Thanks

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach recognizes limit switches then ignores them
« Reply #1 on: May 02, 2012, 05:28:32 PM »
Sounds like you had a faulty switch and Mach has set the active state to Active Low.
Check each switch individually with a ohm meter and then change the active low setting to red cross on your limits.
Hood

Offline kosmo

*
  •  10 10
    • View Profile
Re: Mach recognizes limit switches then ignores them
« Reply #2 on: May 02, 2012, 08:28:52 PM »
Checked the switches and they all show good. I need to make a correction, when in diagnostic screen I can not get the switches to respond in MACH when activated prior to the RESET.
 They do respond on the C32 BOB. I have cross checked the port and pin with the LED's on the BOB(has port and pin # next to LED's). Checked Mach, engaged and active low is checked do to Mach toggle fix before it will RESET.
 I have checked my parallel cables pin to pin and all is good.
What am I missing ?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach recognizes limit switches then ignores them
« Reply #3 on: May 03, 2012, 03:05:27 AM »
Can you attach your xml?
Sounds like its either a config issue or the BOB is not passing the signal.
Hood

Offline kosmo

*
  •  10 10
    • View Profile
Re: Mach recognizes limit switches then ignores them
« Reply #4 on: May 04, 2012, 10:37:50 PM »
Sorry it took awhile, here is the xml file I have set up.  It will show a few pins for spindle relay control and other outputs that are not activated.
My first focus is the safety of the machine from damage so the Limit Switches are my primary concern. Thank You

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach recognizes limit switches then ignores them
« Reply #5 on: May 05, 2012, 04:18:09 AM »
That is a backup xml and not the one you are presently using. Look in the main Mach3 folder and not in the backup folder. Also what version of Mach are you running?
Hood

Offline kosmo

*
  •  10 10
    • View Profile
Re: Mach recognizes limit switches then ignores them
« Reply #6 on: May 08, 2012, 12:09:14 AM »
 ;D
I figured it out !! I have a parallel port issue. It seems that port #2 is not communicating. I ran my limits through an alternate input on the c32 bob that used port 1 pins 11, 12, 13. Now to correct it so my MPG will work! Thanks for the reply Hood