Hello Guest it is January 25, 2020, 03:25:50 PM

Author Topic: multiple tools offset question  (Read 1842 times)

0 Members and 1 Guest are viewing this topic.

multiple tools offset question
« on: April 25, 2012, 11:23:40 AM »
Despite setting and saving a tool off set( it's a shorter tool than tool zero), when Mach 3 goes from a drilling operation to a contouring, with a different tool,
the offset does not take. Essentially, the new tool falls short of its zero point on the workpiece.  I don't get it. 
For perspective sake, tool 0 is set at 0 in the offset table, and the tools preceding the countouring operation appear to work fine, since they all have the same length.  When I change the tool to do the contouring, with an offset of -.500( half inch shorter than tool 0) in the tool table, the program does not recognize it.
Mach 3 does know when it's a tool change.
Any help is greatly appreciated.
tc

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: multiple tools offset question
« Reply #1 on: April 25, 2012, 11:27:19 AM »
G43H* needs to be called where the * is the offset number in the tooltable you wish to call.
Hood

Offline BR549

*
  •  6,925 6,925
    • View Profile
Re: multiple tools offset question
« Reply #2 on: April 25, 2012, 11:29:37 AM »
It really is NOT a good idea to use TOOL 0 in Mach3 as you may have found. It is a reference point for Mach3.

Just a thought,

(;-) TP
Re: multiple tools offset question
« Reply #3 on: April 25, 2012, 12:10:39 PM »
Thanks a lot. It was the infamous G43 that was missing from my code. The post processor Mach3B, for some reason, leaves it out. I had used this on an old program.
tc