Hello Guest it is May 08, 2021, 04:01:29 PM

Author Topic: Mach 3 Kooky-ness  (Read 4438 times)

0 Members and 1 Guest are viewing this topic.

Offline Keith

*
  • *
  •  187 187
    • View Profile
Mach 3 Kooky-ness
« on: April 23, 2012, 09:53:13 PM »
I'm using the lockdown version of Mach. When I try to either insert a number in the DRO or in the MDI screen as soon as I get to the tenth of thousandth place (.0001) it triggers the reset/e-stop on the screen. Not before. It also happened when I put in a thousandth place and then went to type in an 'f' value in MDI page.
Any ideas?-Keith

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #1 on: April 24, 2012, 04:19:53 AM »
Have just loaded 022 and cant seem to replicate your problem. Is there a message in the ticker line? If it mentions watchdog then turn that off in General Config.
If thats not the problem if you attach your xml I will see if I can replicate it here.
Hood

Offline Keith

*
  • *
  •  187 187
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #2 on: April 24, 2012, 05:59:13 PM »
Thanks Hood. No thw 'watchdog' isn't checked.
I've attached the XML but I find a few others in the Mach3 folder that I assumed were deleted when I removed and then reinstalled Mach. I assume they're no problem as long as I'm not calling them up.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #3 on: April 24, 2012, 06:24:56 PM »
Works fine here with your xml. See you have the SS so I am thinking you are losing communication with the SS for some reason and it is triggering the reset but afraid I dont have a clue why :(
Dont suppose you have any keys sey up on your keyboard as hotkeys for Reset?
Hood

Offline Keith

*
  • *
  •  187 187
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #4 on: April 24, 2012, 07:01:27 PM »
I have e-stop set to a hotkey but that doesn't work (and I am assuming it would act as  reset because that's how I tried it once the emergency reset got triggered, never to actually trigger it myself). I know there are some issues with SS and the 'reset' button. I've never used that hotkey as the number I was trying to input though. I'll remove that hotkey if you thik that might be something related. Thanks for your help.
-keith

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #5 on: April 24, 2012, 07:05:22 PM »
Dont know if it would help or not, likely not. I was testing here with a SS and your profile and never got the problem so dont know where to start. Maybe start Mach as  the parallel port driver and see if it happens, that would at least eliminate the SS if it does. Also maybe try a different keyboard or even enable the onscreen keyboard to see if it triggers with that.
Hood

Offline Keith

*
  • *
  •  187 187
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #6 on: April 24, 2012, 07:14:28 PM »
Thanks. I was wondering if it was Windows because since I'm using the SS, I went to a laptop and didn't optimize XP. It all works pretty well (save for a few warnings about the 'SS plug-in corrupt' for instance but still works). I went over that with Greg from SS and tried a few things that didn't help (changing versions, etc.). Still the only anomaly is this problem as far as I can see.
-Keith

Offline Keith

*
  • *
  •  187 187
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #7 on: April 24, 2012, 07:37:25 PM »
OK, fixed. It was the assigned E-stop in ports and pins inputs. I disabled that. I'll have to dig deeper into how that handled with SS. Thanks again for your help Hood.-Keith

Offline Keith

*
  • *
  •  187 187
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #8 on: April 25, 2012, 01:51:40 PM »
Hi again. Hood, you say you tried the Mach 3 version I am using (lock-down) with a Smoothstepper. I assume you have a hardwired e-stop. I would just like to use the screen e-stop/reset for now. In disabling e-stop in config. ports and pins/input, of course I can't use the screen stop. And besides, even though I can input in MDI now, just now, as I was about to, the axis jumped to an arbitrary place which to me sounds like I am still getting some kind of nonsense happening in the MDI window.
Can you tell me, in working with the Mach I am working with and Smoothstepper that you tried, how was the e-stop configured? Did you just use my XML?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Kooky-ness
« Reply #9 on: April 25, 2012, 01:55:03 PM »
Yes I just used your xml and in that the active state of the E-Stop input is set active low. I am just testing on the desktop so nothing attached to the SmoothStepper other than the USB cable.
Hood