Hello Guest it is August 12, 2020, 08:48:44 PM

Author Topic: Mastercam X5  (Read 3613 times)

0 Members and 1 Guest are viewing this topic.

Mastercam X5
« on: April 11, 2012, 05:45:11 PM »
I have downloaded and installed the mastercam postprocessor provided from Artsoft. Made a simple 100 x100mm contour with one pass -10mm deep cut and after I input the g code generated to Mach3 it didn't work properly.  Does the postprocessor provided only works with older version of Mastercam? Here is the g-code generated...


%
O0000 (SQUARE)
(MASTERCAM - V14.)
(MC9 FILE  - T)
(POST      - )
(MATERIAL  - ALUMINUM MM - 2024)
(PROGRAM   - SQUARE.NC)
(DATE      - APR-12-12)
(TIME      - 07:37)
(POST DEV  - NovaLab)
(NWDTOOL N"   10. FLAT ENDMILL" T219 D10. F10. L20. A45. CD20. CL10. SD20. C0)
(NWDSTOCK X100. Y100. Z10. OTC OX-50. OY-50. OZ0.)
N100 G00 G17 G21 G40 G49 G80 G90
N110 T219 M06 (   10. FLAT ENDMILL)
N120 (MAX - Z25.)
N130 (MIN - Z-10.)
N140 G00 Z25.
N150 G00 X5. Y100. S2000 M03
N160 Z-15.
N170 G01 Z-20. F3.6
N180 Y-95.
N190 X95.
N200 G00 Z35.
N210 X-95.
N220 Z-15.
N230 G01 Z-20.
N240 X90.
N250 Y90.
N260 X-90.
N270 Y-90.
N280 G00 Z35.
N290 M05
N300 G90
N310 M30
%
Re: Mastercam X5
« Reply #1 on: April 12, 2012, 12:45:33 AM »
When you say it didn’t work properly, did you mean

1.It was the wrong size
You say it was 100 x 100mm, but the dimensions in the program indicate 200 x 200
Your geometry is wrong, fix the geometry.

2.It was feeding too slowly
Line  N170  F3.6 is 3.6 mm per minute
It would take 55 minutes to go 200 mm
The feedrate is set on the “TOOL” page in Mastercam X5

3.The depth is wrong
You say you went 10 mm deep, but line N160 makes a rapid move to Z-15. and line N170 feeds to Z-20.
The depth and feed plane are set on the “LINKING PARAMETERS” page in Mastercam X5

4.You wanted the tool to be centered on the lines
It looks like cutter compensation (handled in the computer by Mastercam) is on. That shifts the tool ½ the diameter so the cut will leave the line.
Compensation type and direction are set on the “CUT PARAMETERS” page in Mastercam X5

5. You didn't want to use tool number 219
The tool number can be set on the "TOOL" page in Mastercam X5

Let me know if it's something different that's not right, but I don't think there is anything wrong with the post processor

Re: Mastercam X5
« Reply #2 on: April 12, 2012, 01:24:20 AM »
I think the post processor for Mastercam for download over the internet is not
really meant to work well for mastercam x5 :-(

Yes the dimension is only 100 x 100mm and the dept of cut is  only 10mm
using a 10mm endmill.  When I load the gcode generated  to Mach3 it shows
inaccurate cut parameters.

I'm currently using cambam to generate g-codes for mach3 and so far it works well,
but with my mastercam it has been a failure :-(