Hello Guest it is November 14, 2019, 01:45:59 AM

Author Topic: Phantom Limits, Galil error 22  (Read 8645 times)

0 Members and 1 Guest are viewing this topic.

Phantom Limits, Galil error 22
« on: March 05, 2012, 07:57:21 PM »
Please help me.  I'm so close. 
I'm having problems with phantom error switches.  I have only three limits switches.  One per each (X,Y,Z) axis, the positive (+)limit switches.  I've checked these boxes to set up Mach3:
1)to use limits as homes
2)Disable amplifiers when in E-Stop
3)Config Galil Limits active low
The limits mounted are NC switches that one end is attached to the neg/ground (-) of a 5.0VDC power supply, the other end is connected to FLSn (n=a,b,c,d) , pins #36,37,38,39 of the Galil  I/O (A-D)breakout board (BOB).  The power supply’s positive (+) terminal is connected to the LSCOM (pin #6) of the same Galil I/O (A-D) BOB.
Tripping any of the switches or disconnecting any of the wires from the BOB (FLSn, LSCOM) or from the 5.0VDC power supply gives me a limit switch error.  The RESET “LED” in Mach3 flashes… the alarm goes off every 4 seconds or so…and the Status line says Limit Switch Triggered.   Hitting the history button indicates the same “Limit Switch Triggered” 9 times per second until the switch is released or the wire is connected.   This, to me, seems correct.
I don’t have a clue what I’m supposed to do with ports and pins in Mach3 and have left everything there blank.
Jogging any of the motors (X,Y,Z) in the positive (+) direction works fine, unless/until I hit an actual switch.  They could be smoother but I haven’t tuned them yet.  The DRO also indicates the correct direction and amount of movement.
I am unable to jog any of the motors (X,Y,Z) in the negative (-) direction at all because of the phantom switches.  The motors don’t move a bit.  Touching any of the negative jog (-X,-Y, or -Z) buttons causes a Galil Error 22: Begin not possible due to limit switch.  “Emergency mode Active”.  The error doesn’t sound an alarm like the physical switches nor does the history repeat anything nine times a second just the one line… Galil Error 22: begin not possible due to limit switch.  It’s as if there is(are) a negative limit switch(es) present and triggered.
Does anybody know how to tell either or both the Galil DMC4040 and Mach3 that there are NO neg (-) limit switches.  At this time the soft limits are set at 100 and -100 for all axes.
I would post the debug file if someone would tell me where it’s hidden. 
Thank you for any suggestions.

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Phantom Limits, Galil error 22
« Reply #1 on: March 06, 2012, 08:03:23 AM »
You'll need to jumper the negative switch inputs of the Galil breakout board to ground. That should correct the problem that you are seeing.
Having way too much fun! Something must surely be wrong.
Re: Phantom Limits, Galil error 22
« Reply #2 on: March 06, 2012, 03:27:33 PM »
kcrouch,

Thanks I'll try that.  It actually occurred to me that I may have to do something of that nature but the reason I haven't yet was because the physical switches give me different errors than the phantom ones .  I thought maybe it had something to do with ports and pins or some magical setting that shuts off the negative limit switch.  Like I said, I'll do it and see. Hopefully its that simple.  I'll do that tonight and report back either way.
Re: Phantom Limits, Galil error 22
« Reply #3 on: March 07, 2012, 01:47:37 PM »
kcrouch,

Thank You, Thank You,Thank You! 

Yep, you're a genius, or I'm an idiot.  Three weeks of trying to figure it out and simply running three wires from the supply ground to the reverse limit switch terminals (RLSn n=x,y,z,a)on the BOB fixed the problem.  Why missing wires on forward gives different responce than that for rev limits doesn't matter.  I can now jog forward and reverse for all three axes.  Now I'm considering if I should also run three wires from ground to the home inputs for good measure.  Now its time to tune the servos.  With any luck that'll be easy.  Time to read up on that and give it a try.

Thanks kcrouch

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Phantom Limits, Galil error 22
« Reply #4 on: March 07, 2012, 01:59:29 PM »
I would not wire the homes to ground. I would suggest connecing them to the plus limit switches though. You gave the clue when you said that your limits were wired normally closed.  That meane that when not triggered, the signals were connected to ground through the switch, so jumpering the minus limits to ground tells the Galil that there are no limits triggered in the negative direction. You'll need to use the homes and check them off in the plugin so that they will initialize Mach properly at start up.

Cheers,
Kenny
Please PM me with your location, we may be near by.
Having way too much fun! Something must surely be wrong.
Re: Phantom Limits, Galil error 22
« Reply #5 on: March 07, 2012, 05:50:14 PM »
Kenny,

I can try that.  Should I still leave the box checked in Mach3 to use limits as homes?  I haven't tried anything yet and won't until the weekend.  I don't know anything yet about operating Mach3 yet.  I'm going to have to do some serious reading to get to know Mach3.  Your suggestion got me past a huge hurdle in what I hope will become a friendly and functioning bed mill again.  I have more to do yet, but first I think I should tune the servos and get them running smoother.  The plug-in and plug-in instructions for Galil seemed to go pretty smoothly but I don't get what I'm supposed to do with ports and pins.  I haven't a clue what the pages 17 & 18  are about.  "All use port 1" pins 1-22 and 25-32, and 41-48.  So, when you say
"You'll need to use the homes and check them off in the plug-in so that they will initialize Mach properly at start up."  I don't know what that means.


 I live in Rochester MN.