Hello Guest it is December 14, 2019, 12:59:34 PM

Author Topic: Z coordinate shifts randomly when running various gcodes  (Read 3000 times)

0 Members and 1 Guest are viewing this topic.

Z coordinate shifts randomly when running various gcodes
« on: March 01, 2012, 11:24:07 AM »
Hi All

I have a strange problem that is hard to duplicate and is causing a lot of head ache.

I am using Mach3 , G540, Nema 23 steppers. Machine is XP pro SP3 with Pentium 4,  3.0Mhz. I bought my machine from www.cncrouterparts.com (4'x8' model)

Sometimes I can run a job and not have any issues only to run it again later to have Z suddenly half way through. It either comes down or up about around 0.25

So here is scenario I set my 0,0,0 and run my gcode. Half why through I notice the the router is cutting too deep into the material or is too high. I stop the job and goto zero, and Z is either higher or lower!!!

The gcode does not make much of a difference. But I noticed it happens more often if there are more Z movement in the gcode. Happens more often in Pocketing jobs and less in Profiling jobs.

could it be that my cables are too long? My parallel cable is 10' and motor cables are 20' each.

Any idea?

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Z coordinate shifts randomly when running various gcodes
« Reply #1 on: March 01, 2012, 11:53:41 AM »
Decrease you're Z axis acceleration. What is it set to?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Z coordinate shifts randomly when running various gcodes
« Reply #2 on: March 01, 2012, 12:11:46 PM »
I tried it a few days ago. It did not make any difference. It was 15, I changed it to 2.

Re: Z coordinate shifts randomly when running various gcodes
« Reply #3 on: March 01, 2012, 01:08:10 PM »
Do you use a Zero Tool set? I had a problem like this awhile back on my Bridgeport.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Z coordinate shifts randomly when running various gcodes
« Reply #4 on: March 01, 2012, 01:39:08 PM »
Try either increasing the pulse width to 15 or alternatively try sherline mode.
Hood
Re: Z coordinate shifts randomly when running various gcodes
« Reply #5 on: March 01, 2012, 02:56:13 PM »
@ranchak

What is Zero Tool set?


@Hood

I will try to find pulse width and change it. What does Sherline Mode do? and where can I set it?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Z coordinate shifts randomly when running various gcodes
« Reply #6 on: March 01, 2012, 03:22:06 PM »
Pulse width is on Motor tuning page, set both Pulse and Dir to 10.
Sherline mode makes the pulse as wide as it can be, only 25KHz kernel can be used with Sherline. You will find it on Ports and Pins main page.
Hood
Re: Z coordinate shifts randomly when running various gcodes
« Reply #7 on: March 01, 2012, 06:54:18 PM »
Step Plus and Dir Pulse for Z were both 2. I changed them them to 10.

I always had kernel set to 25Khz. Never changed it from default.

What does the pulse width suppose to change? it says 0-5 on top of the field.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Z coordinate shifts randomly when running various gcodes
« Reply #8 on: March 02, 2012, 02:58:29 AM »
It makes the pulse wider, some drives need a wider pulse before they can see it.
It is now I believe 0-15 and then of course you have Sherline mode which is 40uS
Hood